Ruby Console Opens on Startup

Recently the Ruby Console has started opening during startup on my Win10 machine. I’ve tried resetting the workspace, disabling extensions that have been installed/or updated in the last few weeks, deleting the key for the Console from the Registry and still the Console opens.

Renaming the Plugins folder so it isn’t recognized makes the problem go away so I expect it’s an extension doing it. Is there an easy way to figure out which one might be calling the Console without removing/disabling extensions a few at a time and restarting SU? Maybe some snippet that would return some clue as to which one is the culprit?


probably one of mine…

but seriously now, one of the recent beta plugins turns it on [and forgot to comment it off], so you could have a look by date installed?

maybe the new piping one?

I’ll see what I can find…


Thanks John. I’ll look for yours and try disabling them.

I don’t think I installed the piping extension.

Edit: all of yours are disabled and many more but still getting the console.

Interesting thing. I tried disabling LibFredo6 and on restart, I got a bunch of expected error messages indicating that his extensions couldn’t load without it. When I cleared the last message, the console displayed:

My mother-in-law plays a Hardanger fiddle. I wonder if that’s close enough. :smiley:

get her round and find out…

none of my PC ones open RC, I was jesting…

Animator might?


No Animator yet.

It sounds like a cat fight. :slight_smile:

Place this one line script in your plugin folder. And if the console is open, this script will close it.

z_close_console.rb (50 Bytes)

Thanks Guy. It didn’t close the console, though.

what are the last couple of files if you type into RC



This means that an other plugin is opening the console after loading or is loaded after my small script.

"C:/Users/Orbital/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/z_close_console.rb", "C:/Users/Orbital/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/Zorro2.rb"]

My first thought after Guy’s one liner didn’t work was to check Zorro2. Disabled it and still got the console which didn’t close.

That’s what I was hoping, Guy, but that didn’t do it.

you could look for files by age using ctime or mtime

for less than 20 days old use…

files = $"
files.each{|f| next unless f =~ /Plugins/
p File.basename(f) if (( - File.ctime(f).to_date).to_i) < 20};nil

might narrow it down…


We have BINGO folks! Everybody hold yer cards!

Thank you John. It wasn’t in the last 20 days but changing it to show the last 30 days dredged it up. It’s a plugin called CNC-Profile.rb which I must have installed because someone was having trouble with it.

I didn’t remember this happening before Basecamp which prevented me from looking that far back.

I commented out Sketchup.send_action "showRubyPanel:" which also seems to have fixed it.

Thanks all for your help.