Ruby Console not opening

Hi everyone,

Recently my Ruby Console just stopped loading up. In Sketchup Pro 2018 I click on Window - Ruby Console and nothing happens. I tried reinstalling to no avail. I also uninstalled any recent extensions only leaving a few base Sketchup ones but still not working.

Any thoughts?

Thanks,
Dirk

It could be that it is opening off screen. Try going to Window>Preferences>Workspace and clicking Reset Workspace. Any change?

1 Like

But the menu item loads, right?

Ah that did the trick Dave! Wasn’t aware of that but thanks a lot!

Glad it worked. Have you used SketchUp with multiple monitors?

Yes I have two side by side monitors but one is smaller so it may have been hidden above it

1 Like

It’s a common problem that with two monitors SketchUp may become confused about which monitor the remembered coordinates of a window refer to, especially if you disconnect one of them. That can cause the window to be off screen or unexpectedly hidden behind something else.

Use command ` to cycle through your windows on Mac (like command tab to cycle through apps, but it stays just in the windows of the current app).

I have the very same problem. I juts moved my SU license to a new computer. There are currently two monitors with the same 1920x1080 resolution connected. (later on I intend to attach a 3. monitor with 4k resolution).
Unfortunately even
Window>Preferences>Workspace is out of both screens.
Sketchup 2018 on WIN10 can be closed only with either pressing CrtlAltF4 or via the task manager.

I tried this very simple ruby code


It does not work either.

Go Window/Preferences to get focus on the dialog, then Alt and space together followed by m then tap any arrow and finally move the mouse around(without clicking) until the dialog comes into view. Then reset the workspace.
Some other dialogs may need this treatment too.

Thank you for your help.
Unfortunately it is not working either.
I did exactly what you suggested. A cross cursor appeared it was moved around both screens but nothing happened.

However I found a very nasty solution.
For security reasons I very rarely logon as administrator on my PC.
SU 2018 was reinstalled.
As a user with administrative rights all the windows are Ok in SU.
If I logon as a “normal” user the windows are off screen again.

Sounds like you didn’t tap the arrow key.
The other option is not to tap the arrow but click and hold the left mouse button while you move back to the screen.

Many settings of SketchUp, including preferred window positions, are saved separately per user, so this is not surprising. By the way, you should install SketchUp by logging in as an ordinary user, right-clicking the installer, and choosing “Run as Administrator”. That does not have the same effect as installing while logged in as an Administrator.

Thank you for your help.
I tried it.
I did the following

  1. delete the directory …\appdata\roaming\SketchUp for the normal user

  2. Log on as admistrator

  3. delete the directory …\appdata\roaming\SketchUp for the admistrator

  4. Uninstall SU

  5. log on as normal user

  6. Install SU2018 “Run as Admistrator”

  7. start SU as normal user

  8. The windows are off screen again

  9. log off

  10. log on as admistrator

  11. start SU

  12. Works fine

  13. Copy into a temporary directory …\appdata\roaming\SketchUp for the admistrator

  14. Log on as normal user

  15. overwrite …\appdata\roaming\SketchUp with the admistrator roaming files

The result is the same the windows are off screen.

So my question is where are the preferred windows positions are stored?
(It is obviously not in the roaming directory)
I would like to make a “clean” reinstallment i.e. I would like to erase completely the previous installation.

Thank you for your suggestion.
Unfortunately it did not solved the problem.
I uninstalled SU2018 then reboot and regedit.
All the sketchup registry entries were deleted.
Reinstall SU .
The result was the same.

Finally the problem was just dodged/sidestepped.
A new windows user was created.
for this new user all the windows are in the right position.

Are window positions still saved in the registry or have they also been moved into one of the new JSON files?


The shared preferences contain most of the personalization (your settings in SketchUp preferences, extension settings), so you want to keep it. Preferences that relate to the application state and depend on the platform are stored separately in private preferences. Some remaining settings internal to SketchUp’s installation are still in the registry.

Gyula, you may have a look in the “PrivatePreferences.json” file (open it like a txt file in a plain text editor) whether it contains something related to “workspace”, “toolbar” or “window” positions. If so, backup the file to another location (so you can restore it) and delete it at the original location, then restart SketchUp:

  • Windows: C:/Users/<user>/Local/SketchUp/SketchUp 2018/SketchUp/PrivatePreferences.json
  • macOS: /Users/<user>/Library/Application Support/SketchUp 2018/SketchUp/PrivatePreferences.json

Thank you!

That is the solution!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.