Ruby Console not opening


#1

Hi everyone,

Recently my Ruby Console just stopped loading up. In Sketchup Pro 2018 I click on Window - Ruby Console and nothing happens. I tried reinstalling to no avail. I also uninstalled any recent extensions only leaving a few base Sketchup ones but still not working.

Any thoughts?

Thanks,
Dirk


#2

It could be that it is opening off screen. Try going to Window>Preferences>Workspace and clicking Reset Workspace. Any change?


#3

But the menu item loads, right?


#4

Ah that did the trick Dave! Wasn’t aware of that but thanks a lot!


#5

Glad it worked. Have you used SketchUp with multiple monitors?


#6

Yes I have two side by side monitors but one is smaller so it may have been hidden above it


#7

It’s a common problem that with two monitors SketchUp may become confused about which monitor the remembered coordinates of a window refer to, especially if you disconnect one of them. That can cause the window to be off screen or unexpectedly hidden behind something else.


#8

Use command ` to cycle through your windows on Mac (like command tab to cycle through apps, but it stays just in the windows of the current app).