Roof inclined and rounded


I need to create a inclined and rounded roof that follows a specific path

how can I make it like the one in the picture?

i attach the rendering and the sketchup file with the shape that i need



1.skp (177.2 KB)

I can think of a number of different ways to do this. One would be to create a helical path with Curve Maker and then use Eneroth Upright Extruder. Both extensions are available in the Extension Warehouse.

Start by cleaning up your existing geometry. There is a break in the inner spiral that prevents it from forming a continuous path. The break is small and offset. You may be able to fix it by moving the upper part of the spiral a bit, but it might be simpler to redraw it using an extension such as Curve Maker. The vertical edges around the outer spiral will just interfere with what follows - erase them.

With all that done, use Eneroth’s Upright Extrude extension to extrude the face around the curve. It is necessary to use that rather than native followme to avoid having the surface twist off level as it follows the curve.

That’s essentially what @DaveR posted while I was typing, though he used the outer spiral whereas I suggested using the inner one. It probably doesn’t matter in this example, but often a shape will extrude better using the inside rather than the outside due to the way SketchUp handles extrusion.

Steve brings up a good point. Sometimes especially with the native Follow Me tool (which wouldn’t be the tool of choice in this case) it’s better to create the path along the inside instead of outside. In this particular case that’s not a problem.

how can I adapt the spiral to my path?

thanks, I understand everything!

The only problem I have now is to adapt the curve with Cruve Maker to mine

also the curve made with Curve Maker is horizontal but mine is inclined

I only used Curve Maker to draw a clean helix. If your path isn’t helical, you’ll need to draw the path some other way. With the dimensions of what you drew being as they are, it’s difficult to know what is actually correct. Is this the correct width for the ramp?
Screenshot - 9_9_2020 , 8_06_53 AM

One thing you should d o before continuing with the model is go to Window>Model Info>Units and turn off Length Snapping. Also I would suggest setting precision higher so you can see what the dimensions actually are as you are modeling.

the measure is 9998 mm

i turned it off.

so i have to create a new spiral?

I don’t know that you have to create a new one but due to the dimensions I could clean out of what you provided, I have no idea if what you have is actually correct. There’s not much to your model yet so if there’s any errors, it’s probably easier and faster to start over than repair what you have.


can you upload the one you made?

Here you go. It’s probably not correct in its dimensions because I guessed at some of them. For example I made the ramp/roof 10 meters wide because 9.9978195 meters didn’t seem right to me. Actually neither does 9.98 meters but you know the project and I don’t.
1.skp (133.3 KB)

By the way, please complete your forum profile with SketchUp version and the correct operating system and graphics card.

can you upluad in an older version? i have pro 2018

Here it is saved for 2018.
1.skp (139.3 KB)

And that’s a good reason for having a complete profile.

1 Like

thanks, i will go on trying

updated the profile!