Reverse Faces with keyboard

I’m used to right-click on a surface in order to reverse faces.
Typing “R” after right-click used to do the job but since the latest version I have to click on “reverse faces”.
I think I need to change the settings but haven’t got a clue where.

Keyboard Shortcuts under preferences… personally I use “ALT-F” for flip faces

You must have altered the shortcut to [R] yourself because [R] is default for the ‘Rectangle’ tool.

Normally you right click on a (sur)face and select ‘Reverse’ in the context menu.

First step to help is to assign a shortcut key to the ‘Reverse’ operation (this could be [R] if you prefer). You then still have to preselect the (sur)face.

Second step to help is to preselect:

  • either the ‘Move’ tool. Now hover over the (sur)face and hit your [R] to reverse. Disadvantage is that the (sur)face gets unselected after the operation unless you slightly move the cursor.
  • or the ‘Push/Pull’ tool. Now hover over the (sur)face and hit your [R] to reverse. Advantage is that that (sur)face stays selected after the operation. You can easily hover over (sur)faces with the P/P tool to subsequently hit [R] to reverse a series of (sur)faces.
1 Like

There’s a difference in “right click context menu” and just regular keyboard shortcuts. I used to be able to select an object, right click on it and hit H for hide- that is gone, or in the OPs example- right click on a face and hit R to reverse the face. Versus not right clicking and drawing a rectangle with R. I’m still fine with H meaning “hand” or R for rectangle. The OPs saying their (and my) right-click context menus aren’t working. Just did an update and restarted a few minutes ago, hoping it would fix, but no luck.

I believe this is a result of porting SketchUp 2023 to use the Qt GUI library on Windows. It seems that firing the menu item starting with a typed key was default behavior in prior versions (regardless of shortcut settings for the same key), but this no longer works in 2023.

Oh wow. So that’s it? It’s dead? Sometimes it actually still shows up as an Underlined first letter in the context menu like it used to-but doesn’t work, is this just a tease?
As someone who works professionally with Sketchup, this is a huge productivity setback. The fact that I’m the only one that noticed it, makes me sad for users who are wasting their time with millions of unnecessary clicks versus right hand on the mouse, left hand on the keyboard and flying through their day.

Right click menus aren’t all dead, I just noticed one that still works. It’s in the scene tabs- thank goodness this one still works. I just did right click U and updated my scene. So, maybe there’s some hope that the rest of them will be fixed?

Interesting, I just looked at 2021, and none of the first letters are underlined as in each of your examples.

I’ve been absolutely using context menu shortcuts for way longer than back in 2021. On a PC, since everyone using a Mac only has 1 mouse button (ha) maybe they didn’t bother to put them on there.
But to update my excitement about the scenes tab, U is the only one that works, I can’t Add, Rename, or Delete with one key anymore. So, I’m leaning towards glitch VS feature (or lack thereof).