Results of Validity Check then crash

Hi I’m trying to open this file and suddenly it keeps crashing… I get this Validity message then opens ok then will crash after a minute or if i click anything… have tried on 2 macs… I don’t think its happening on PC… can any one help me? Ive spent so long today trying to fix…


I have uploaded file here

I saw a tag with no name when I loaded your model (without fix). Changed it to “blank” and so far the model hasn’t crashed SketchUp on my Mac. Model Info ->statistics->fix problems found a few more things to repair (unrelated to tags), and it still isn’t crashing. I can see why a blank tag name would be unacceptable, but it should have been trapped not cause a crash!

Are you getting a BugSplat when it crashes? If so, are you sending the reports in? It would help customer support if you cite this topic in the crash report and the copy the crash number here.

If you aren’t getting a BugSplat, that usually means that SketchUp aborted due to an unrecoverable error that doesn’t fit any of the standard crash reasons (signals, in macOS). This kind of suicide can’t be trapped by BugSplat, but does leave a crash report in

~/Library/Application Support/Logs/Diagnostic Reports

Edit: getting blank or one-character tag names is a long-known issue with the SketchUp GUI on Mac: unless you click outside the name field, the next thing you type overwrites the name you entered. Typically it’s a shortcut for a tool, and space (for select) is very common.

Edit 2: It appears that this cut through the wall was the only thing using that unnamed tag

Firstly thank you for taking the time with a lengthy response! Amazing you found that blank tag.

Yes I am getting Bug spats each time… have sent todays report back referencing this post.

Problem is I can’t get into model to blank label tag, keeps crashing… please are you able to send me back that file you fixed?

I tried opening file again and managed to click on tag, it seemed to have some chinese characters in it? I changed it, but then when I saved it crashed again…

thanks but I think you may have sent wrong file?

Oops! You are right. It will take me a bit to put it on a file share (too large for here) and it is dinner time here. Later…

no worries, thanks so much! Maybe dropbox?
I really appreciate all your help!

See if this works or if I botched it.

ok the first time I opened it, crash…
second time seems ok? I even made a change and saved… progress!