Resolving "This does not appear to be a SketchUp model!" errors

I haven’t the foggiest, but twice now I have ran into a model that appears okay one day, and then the next prompts me with the message “This does not appear to be a SketchUp model!” on any of my devices.

I’ve been working on my models through the web app on OSX with Safari, Windows 11 with Brave, and on an iPad Pro via the app. The error has coincidentally occurred twice when attempting to open them using OSX on Safari, after having worked on them using Windows 11 with Brave. However, this is not a guaranteed behavior.

Any insight would be greatly appreciated.

Follow up:

To anyone who see this: I can consistently reproduce the problem with these files anytime I open them using my Mac with Safari, Brave, or Chrome. The files become corrupt after attempting to do so, and have to be manually fixed. I can only edit them on IPad or Windows. Big sad.

Do you keep a copy of the files in your local drive or just on your Trimble connect account? Can you share the files so we can check if they can be opened on the desktop version of sketchup?

There is something that was wrong with the watermark you are using. I can’t yet tell what was wrong with it, but here are both files with the watermark repaired.

Studio 4.2 3D bad #1.skp (1.8 MB)
Studio 4.2 3D bad #2.skp (1.7 MB)


Amazing! I will refer to a file diff of what you’ve done so I can solve for future errors. I’ll post again with any specifics if they’re relevant.

What do you typically use to best view the contents of a skp file? A hex editor?

What version of SetchUp are you actually using? Your profile says you have SketchUp Go but the watermark thing would imply SketchUp Pro.

My subscription is a Sketch Up Go version. I use the web app and the iPad Pro app. The web app doesn’t show a version per se (the changelog shows updates as of Oct 24), but My iPad shows version 6.3.2 (2011)

I’m curious because it doesn’t appear that you can add a watermark in SketchUp for iPad and the “This does not appear …” message is very uncommon with SketchUp for iPad and Go.

Ah, I can at least guarantee none of my files have been used with the desktop app.

1 Like

We have internal tools that can be more forgiving when looking at problems in the file. I will use your file as an example to show the developers, and once they understand what is odd about the watermark, it should be possible to add the same fix to SketchUp itself.

I did compare the watermark before and after applying a fix, and it was identical, so it may be something about the meta data that is different, and not exactly the image itself.

1 Like

Hi Colin, following up: I can reproduce this error whenever I open these files on Mac using Safari, Chrome, or Brave with the web app. The files become corrupt and I have to manually repair them before I can use them again on Windows (with the web app) or IPad (with the App Store app).

Hi Colin, please kindly help me with my file. My SketchUp got crashed and then I got “This does not appear to be a SketchUp model!” error message when trying to reopen the file. I have no recovery file and even the .skb file cannot be opened. I really need my file back and this is an urgent job. Please kindly tend to my file when you have time. I’d really appreciate your help.
MBTT CHUA HUE LAM_240125.skp (6.5 MB)

Unfortunately, the file contains only zeros, there is no chance that it can be recovered.

Upload your .skb file… perhaps there is an additional little chance

Here’s the .skb file. Please see if there is any chance to recover the file. Thank you @dezmo

:frowning: I can’t download Wetransfer at the moment (corporate firewall.) But maybe someone else will come and try to help…

1 Like

Failed to open. Can you remind me @Dezmo what you open the file with to view the contents?

I’m using Total Commander internal viewer (Lister) which allow me to see any file as text, binary, hex…

1 Like

I’ve tried Lister and see that the .skb file contains about 60% zeros, only 30% left. How do I recover the SketchUp file from here?

Lister is just for checking. Cant do any recovery. 60% zeros is a bad sign, Maybe @colin can do some magic when he wakes up and see your post…

1 Like