Resizing an object with precision?



I want to do something VERY simple and it’s driving me crazy. I’ve seen a dozen other posts asking similar questions, but the solutions I’ve read either don’t work at all or do something other than what I want.

I am designing a desk / cabinets. When I designed it, I made the length of one object too short. So I want to increase it. I want to increase the length so that the new length is exactly 12 feet (it’s currently 11’ 1").

I can click and drag the edge with the mouse, but no matter what I do, I cannot get enough accuracy with the mouse to make it exactly 12 feet.

If I was creating a new object from scratch, I could just start dragging and then type in 12’. But since this object already exists, the Measurement doesn’t show the total length, it only shows the difference. And typing in a value has completely weird and incomprehensible behavior. I’ve tried typing in the total length I want or typing in the difference I want and neither of these works.

Several of the other posts talking about using the tape measure. I tried that, clicking on the edge and then typing in a new length, but that seems to resize everything in my entire space, or at least everything related to the object - essentially scaling the entire thing, which is no what I want. I only want to change the length of one part.

Then I tried using the tape measure to create a reference point, which shows up as a dotted line - figuring that when I use the Push/Pull tool, it will snap to that line. But it doesn’t.

So what do I do here? How can I resize the length with precision?

I am attaching a screen shot of what I have. You can see the wood floor below and a sort’ve shelf (which is the top of the desk). I colored the edge with brick so you can see the edge I want to move. And I want to make that edge line up with the dotted line on the wall to the left of it.


Start the PushPull process then keyin 11.and press Enter


You ought to be able to get pushpull to snap to the guideline created by the tape measure. I can’t explain why that isn’t working for you. If the shelf is a component, of course, you have to open it for edit before you can pushpull its end at all.

snap push pull


One thingI haven’t seen suggested yet is that you should probably make the guide point or guideline before you open the component for editing. Otherwise, it’s quite easy to move it by mistake along with the end of the component, so there isn’t a fixed point or line to refer to.

And I find it easier to snap to a guidepoint rather than a guideline, so use the tape measure from one corner of the component - that gets you a point instead of a line which would be drawn by using the tape measure from an edge or a midpoint.

And you can’t snap onto the dashed line created along with a guidepoint - just to the point.

If however you create a guideline as Steve shows, you should be able to snap to that.


For a shape like that, use the scale tool. Start the move in the direction you want to go and type 12’. As long as you include the units the scale tool will adjust the total dimension.


Inside or outside the component’s context doesn’t really matter. Push/Pull will snap to guides and guidepoints that are in the same context as well as those that are in the higher level context.
In fact even to guides in lower editing context (in a nested environment).


This absolutely does not work. When I try 11", nothing changes. If I try 1", it goes the wrong way and adjusts by far more than one inch. It seems almost completely random. Whatever number I try, I get completely bizarre results.


This also does not work. The scale tool scales the HEIGHT of the object in addition to the length of that one edge, so it’s useless because that’s not what I want.


I’m not really sure what the difference it between a guide point and a guide line. I used the tape measure horizontally and it created the vertical guide line for me and I’m not sure why. Sometimes it only creates the line I drew and sometimes it creates the perpendicluar line along with it. I’m still learning.

But this seems to be the key point I was missing. If I drag so that my mouse is right on the point and not just somewhere along the line, it seem to work. So thanks very much for that. :slight_smile:


Obviously operator error.


A guide line is an infinitely long dashed line, which is created when you use the tape measure tool and start with a click on an edge or a midpoint.

SU can snap to anywhere along a guideline as if it were an edge

A guide point is created when you use the tape measure tool and start with a click on an end point, intersection or other point that is not a midpoint. SU can snap to the point itself, but not to the dashed line between the first clicked point and the guide point created.


It’s scaling the height because you’re grabbing an outer corner, indicating a scale in two directions. Grab the center handle (green dot) on the end you wish to move.


It creates a guidepoint unless the second clicked point is also a point (endpoint, intersection and now midpoint included). Since there’s no need to create a new exact inference location trough creating a guidepoint SketchUp will create a guide instead.


Scale tool does exactly what you want, as @endlessfix said, it depends on the handle you are grabbing.

Let’s say you draw a box:

Don not worry about dimensions, select the box and make it a group (or component)

Then as @endlessfix said, choose the right handle for the direction you want to scale:
(In this case I want to scale the height.)
Though scaling displays the scale factor in the VCB, you can enter a precise measurement as well! You would have to tell which unit e.g. here I type 40mm, the measurements VCB is above the entity info panel):

If you grab another handle, you can type in more dimensions, watch the tooltip and select the right one. Then type in the two dimensions with units, separated by the used separator (; or,)
Two dimensions:

Or all in one with the three dimensions. Note that the order is Red,Green,Blue, so check how your component or group is drawn in your model.

First select scale tool, click once on the appropiate handle, let go of the mouse and then start typing the dimension(s) with units, press Enter, done!
You can’t have more control then that, I guess…


the scale tool will do the trick… you have 133 inches and want it to become 144 inches… divide 144 by 133 and you get a scaling factor of 1.08270677
select the entire object and select the scale tool and pull in the direction you need to grow. then type in that factor number and press return (enter). thats it.
now beware that if the object has a texture applied to it, the texture will get deformed.


Computing the scaling factor is an unnecessary (and cumbersome) step. The scale tool accepts direct dimensions as well as relative scale. If you want it to become 144 inches then simply start your move with the scale tool and then let go of the mouse and type 144". Done.


I don’t think that is correct. The scale tool scale with a factor number, it will not change to a giving dimension. If you type 144" while using the scale tool, it will not become 144", it will become “huge”. You will be scaling with a factor of 144!


Actually, you are mistaken.It’s easily tested.


Ahá! Thanks for that Dave!! I didn’t know that. It is a matter of not forgetting to type the unit you are working on after the number.


Right! Just type it as you did in your post. :wink: