Resizing a Model With Downloaded Components


#1

I have this model that I made:

The motor and prop are from the 3d warehouse, and I’d like to try to resize it to see how large the various parts will end up. If I use the tape measure and measure a known part, give it the new dimension (in this case I chose the wingspan and gave it the new dimension of 48") and when I do I get:

and when I click yes:


(the motor is under the wing)

I don’t believe that either are dynamic components:
image

How do I make this resize correctly?


#2

This is super annoying. For some reason imported components are treated as some sort of edge cases, as if their scale was known to be “correct” just because they are imported, and therefore don’t scale with the Tape Measure tool. They still scale with Scale tool so even if that assumption had been right it doesn’t make any sense.

Anyhow, you can get around it by grouping everything, scale the group from the outside, and explode the group, as this special treatment of linked components only apply when they are in the active drawing context.


#3

Huh, I was hoping that there was some way to do this with the tapemeasure, since what I want to do is set some dimension to a specific value (like what if I make the wingspan XXX?) and see what the rest ends up like (mostly thinking WRT to materials usage…), and my ■■■■ retentive mind will go crazy when scaling by a factor and the closest I can get it is XXX.3 or something.

Is there any way to turn the imported stuff from the 3D library into components like the ones that I made? I have a few ideas like downloading them separately, opening them in another copy and pasting them in this file/model? These things were horribly scaled anyway, for example the motor was appropriately sized for the model and when imported it was larger than the whole thing.


#4

It is just a matter of context, if you group what you have drawn without the external components, you can enter that group and use the tape measurement tool for resizing that particular group.
If you want the other components to be part of it, explode the outer shell and, while still selected, group it or make a new component. Then resize model with the tape measure tool

They can also be moved after being inserted, it does not mean that you have to move the rest of the model, if you inserted it at the wrong place.
Suppose you have taken the effort to resize the imported component, you wouldn’t want it to do it again, after resizing the model?


#5

You can use Tape Measure tool! Just group everything, and then resize the model as a whole from the root drawing context. The annoying special handling of linked components only applies when they lie directly in the active drawing context.


#6

You may find it annoying but I see it as a simple opportunity to let certain (imported) components keep their own size while resizing what you have been modeling. It is there for a reason. And if in the event you do wish to also resize these components, then there are several simple ways to do so.


#7

The problem is that it is not an intuitive behavior and you don’t have much control of it. It is useful if the linked components happen to be of a real world size and the internal aren’t, but it could just as well be the other way around, or split randomly between the two.

Also there are no cues for this behavior so you have to accidentally stumble upon it to find it. It definitely breaks the principle of least astonishment, being a very arbitrary exception.

There are work-arounds for it, like making a temporary group, but there are equally simple work-arounds for not having the scale apply to components of your own choice, such as cutting them before scaling and pasting them after.

Most of the SketchUp UX is pure genius but in my view this specific detail is just bad design.


#8

This discussion makes me feel like I just walked into the middle of an argument that I don’t quite understand. I honestly don’t get what the problem is/why it exists, but typically when I post here it’s because I run into something that “is not an intuitive behavior,” and I can’t seem to find an answer or a clear answer googling (in this case I didn’t see any answers that directly covered the problem I was seeing).

Honestly after playing with this and “fixing” it I’m even more confused.

Anything I tried to do with it in my current model caused sketchup to crash.

Before I had an answer here I re-downloaded the motor model and saved the file, opened it in another sketchup window and tried to resize it there, select it all and make it a component and about 90% of the time it would crash somewhere in that process. I finally copied it from there into my drawing and it acted like it worked.

I tried the same with the propellor and it didn’t seem to work (prop still moved when you resized the model). I tried exploding it and renaming it (there was something weird going on, I ended up with it in my original model as 3 differently named components, I’m not really sure how, they seemed to show up and go away on their own as I recovered from crashes, though it might have just been confusion from the crashes, there where A LOT) and I finally have it and it seems to be working correctly but I can’t really tell you why and how I got there.

I think in the end there’s something wrong with the motor model that is causing things to crash and leading to a lot of confusion on my end, it appears to be saved at 10x it’s actual size and when you scale it to .1 things get weird but not consistently weird (link to the original model in the 3D warehouse):


#9

The “argument” isn’t that important. Getting you on track is. With or without so called workarounds.
What is the actual name of your motor in 3D Warehouse. Just ‘motor’ isn’t helping and I can’t drag the model you showed into the SketchUp modeling instance, the program.
I need to look for the ‘motor’ model in 3D Warehouse from within SketchUp.


#10

You have to click on the “3D Warehouse” text near the bottom right of the preview view. I can’t post a link to the page or it’ll just show that same SketchUp Free style view that Silverback posted. You could remove the space in the following link
h ttps://3dwarehouse.sketchup.com/model/ue31d258a-9931-4b36-be11-c0c2a9d20d4e/ST2204-Donkey-Hobbyking


#11

Clicking “3D Warehouse” didn’t do me any good, hence my asking.



Oops, I tried again and I must have gone straight away to the 3D view the first time and missed the link.

Anyway, thank you for the link in text too. That also worked just fine.


#12

For some reason I’m not seeing updates to my own thread…

Sorry Wo3Dan, but yea, that is what it does with a link, didn’t think of posting it with a space in it or something.

Any clue what is going on?


#13

Do you mean you still don’t know how to resize to exact desired dimensions? Motor or airplane? Or both?