Requests & discussions


#1

Hello Folks,
New in Sketchup but very excited to be part of this great community !
I have designed my house in 2D and now want to lift all the walls at once but can’t get the dotted zone in the walls thickness to do so. An ‘audit’ of the walls doesn’t show any open area : EnregistrementAuto_Charmozes 4.skp
Can you help?
JP


#2

Your post named a file but didn’t upload it. Either drag-n-drop the file into the reply edit window or click the 7th icon from the left at the top to start an upload dialog:


#3

Oups !

EnregistrementAuto_Charmozes 4.skp (1.5 MB)

Thanks !


#4

You can only pushpull faces and there are only a few faces (doors and windows?) between your walls. So to do what you need, you must generate those faces.

To begin, your model has a fair number of ungrouped edges and faces associated with layers other than Layer0, and that has likely contributed to your problems. In SketchUp layers do not isolate geometry; edges and faces will interact with others even if the others are hidden or are associated with a layer that is currently not visible. Among other things, that can cause points to snap to things you didn’t expect and can break edges you thought were continuous. If you edit the style to turn on endpoints, you can see quite a few places where the edges of your walls were broken due to this effect.

As to why faces did not form between the wall edges, I am not sure but it may have been an artifact of the layers issue. To fix it, first get all edges back to layer0 and put the ones that are not part of the walls into Groups or Components. You can associate those Groups or Components with non-visible layers to get them out of the way. Then draw a large rectangle on the ground plane surrounding all the walls, select all, and right-click->Intersect Faces with…->Selection. That should create the missing faces between the wall edges, as well as some others such as floor spaces that you may want to delete. Once there are faces, you can push-pull them up to height.


#5

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.