Requesting Help with Rendering Problems with OBJ export from SketchUp

render
export
modeling
obj
uvmapping

#1

Hello, seeking troubleshooting assistance with another school model. The issue is again upon exporting to another software - Poser and DAZ 3D Studio in this case, prior problems in KeyShot and Maya - the render has serious errors.

https://1drv.ms/u/s!AhVfvSO8cV8chS3mY9TqXNSRmSmO

It appears, for lack of a better description, there is a “break” somewhere in the geometry and it “bleeds” out to create stray polygons that look like streamers created with incorrectly facing Normals. This is not the case, however, as I use a specific Blue/Yellow high-contrast scheme to reveal any errors with misplaced Normals. I have had the same problem with models built exclusively in Maya as well, suggesting it is a geometry problem versus being exclusive to software.

Originally, the models were exported in default colors, and the “streamer” problem persisted. Then all parts were colored in SketchUp to clearly establish Material Zones, yet the problem persists.

Robot Arm Section. All conspicuous features, such as curves and chamfers, are made from Quads. No Tris are used anywhere in my models. The large flat areas of course, create N-Gons. Note the high-contrast yellow, showing a hole in the cylinder socket that was sealed before OBJ export.


Geometry visible:

Note the high-contrast yellow. I do not believe the issue is with incorrectly facing Normals.


After sealing all holes during construction and double-checking all Normals are facing correctly, the test renders my friend did showed this. The dark areas along the sides are stray “bleeds” in the render that hide the chamfered insets:

Serious issues where the OBJ Export does not correctly recreate all Edge Lines. They are there, but not recognized by the software upon rendering. Note the voids in the contour lines of the Chamfered Inset:

No idea why it fails to see all of the chamfered inset:

Note Chamfer Inset geometry:

Inset is lost, despite the part being present. My colleague believes it is due to a registry line I used for construction needs, visible as the heavy “shadow” in the render

Next step, I eliminated all chamfer insets to simplify the model, yet there were still issues with the render. Defined creases “melted”. I would guess from lack of Edge Loops as with Maya? Also more creases and “streamers” that should not be there.

I need help, please, in understanding what this problem is. I do not know what to call it, making searching for information difficult. I REALLY NEED to solve this rendering problem, as I am trying to build props for my friend’s 3D Comics, but also trying start up a garage business of 3D models for Poser and DAZ 3D Studio.

This problem has held me back more than two years now. I have no illusions over the job market in the game or movie industry, I will be graduating college soon; so I must do something to build a real world portfolio of marketable items to “get my foot in the door”. There are artists who make their living with their 3D model business on sites like TurboSquid, CG Trader, DAZ, Renderosity and others. I may actually need to resort to that . . .

As my resume gets deleted the moment the software filters read “United States Army Veteran”. Discrimination that can be explained away as the perils of a “Buyer’s Market” for employers. I doubt any human eyes have ever read of my experience and qualifications or I would not be getting increasingly desperate about future employment.

Thank you for your time.


#2

The “streamers” look like the result of z-fighting to me. That’s what happens when 2 surfaces are right on top of each other. After looking at the model, I’m guessing that it’s some oddity relating to the way the geometry gets tessellated. The voids in the contour lines also look like the result of 2 overlapping surfaces. I don’t see 2 faces in the skp model, so it has to be something happening either on import from SketchUp, or import in to the other packages you named.


#3

Triangulate All Faces: Select this option to break the output into triangles instead of multisided faces.

Export Two-Sided Faces: When you select this option, faces are exported twice: once for the front and once for the back. Although this doubles the number of polygons in the exported file, the model will look more like it appears in SketchUp. Both faces will render, and materials applied to the front and back faces are preserved.

Export Edges: When you select this checkbox, SketchUp line entities are exported as OBJ line entities. If you leave this checkbox deselected, edges are ignored. Usually, this checkbox is deselected because most applications ignore edges when importing OBJ files.
From SketchUp Help

Have you tried disabling any options in the OBJ export? You probably don’t want to export Two-Sided Faces, or Triangulate All Faces. Not sure why you would want to have Export Edges enabled either ::shrugs:: Not sure which, but I think one of them should do the trick.


#4

the torn surfaces you see are the result of poor UV interpretation by the importing software…

if you export with only the default or other colour the UV’s will be missing…

some renderers require you to add a texture material in SU first…

if your object can’t get the UV’s right in SU than is likely to fail when exported…

applied_texture_v6.skp (3.0 MB) saved as v6 to reduce the file size for posting…

once I applied a ‘projected’ texture, I over-painted a couple of the rings with a colour and added the recess just to test…

the actual image is done in v16 using Visualizer after I scaled the texture down till I liked it…

there are thousand of posts about how SU handles UV’s at SketchUcation forum…

john


#5

And besides the native OBJ export …


#6

I did a couple of quick renders in Kerkythea. I did nothing to modify the geometry in SketchUp. I did apply the wood grain materials in SketchUp.


#7

@DaveR, I wooden do it like dat…

john


#8

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.