Replicating 3D objects efficiently


#1

Hi, I am designing a cupboard with flexible shelving. For the shelving I am adding 6 holes for each level to both sides. Each side wall has 20 levels and I used rectangular shapes to indicate the position of the holes. To add the 20 levels, I tried to use copy/paste which didn’t quite work as every time I tried to align the pasted group with a corner point of an rectangle, it turned the hole 90 degrees sidewards. Moving with Ctrl worked better as it did’t turn the holes, however, it didn’t copy the barrels that are inside the side wall.

I checked videos and other posts, but neither gave me some more ides.

If you have an object (such as a hole in a 3D object), what’s the best way to replicate it?

thanks
Peter


#2

To start check out these videos: Getting Started
Basically follow the .gif, do NOT click in the measurements box just let go of the mouse and type in air.


#3

As a general workflow, when you have a number of holes in a basically flat object, it is best to draw one face of the object, draw the outline of the holes on that face (use the array copy mode of the Move tool to generate multiple evenly spaced copies. In the animation I didn’t have the measurements box visible, but in that pause before the third hole appears I just typed 2x), and then pushpull the face to the required thickness. Also note in this animation that I moved the hole by selecting it, activating the Move tool in copy mode, and then clicking on an edge and moving the cursor along that edge. That process assures that the copy moved parallel to the edge without explicitly doing an axis lock. Handy when the edge isn’t parallel to an axis!

holes


#4

Thanks, I’m familiar with the tutorials and the basic movements. I still don’t know how to effectively get those holes in post adding thickness to the rectangle. @slbaumgartner - I initially didn’t plan to have the holes going all way through - hence the different sequence.

Thanks,
Peter


#5

If I understand the question correctly, carefully “right to left” select the geometry of the hole. (X Ray view style can help sometimes), Then use the Move tool and tap the CTRL key to create the copy.


#6

I do it this way, but it copies the barrel and the circles on each end, however the holes aren’t empty - both sides are closed in the copy.


#7

It sounds like maybe a context problem to me, note that I draw the circle “inside” the component, on the face geometry. Do you have a sample (SKP)you can upload here?

I’ll try the same in FREE (web) your version meanwhile…EDIT Yes it works in the web version same as above too.


#8

Not sure what I do wrong - I created a test model and I have the same issue. When I move the hole, it works fine, but as soon as I press Ctrl, the hole closes up. The circle doesn’t intersect with the surface even though I move it along the axis. Is this perhaps caused by a setting?

hole test (1).skp (292.3 KB)

What do you use to produce those gif animations?


#9

Licecap is one screentogif is another, both are free


#10

Thanks


#11

I use Licecap.

Just try again with only a partial depth hole a few times, see if you can get that going. Make sure you select all the geometry of the hole. Partial works, but full thickness don’t. I think full thickness will require a different approach…

Steve showed one way earlier for full thickness, there are others too.


#12

Partial depth works fine for me too.

EDIT: I now tried another approach - I had already some other partial depth holes - hence I was reluctant to start from scratch. But I cut the two parts off, had only one rectangular with holes, copied those - so far so good. The next step was to pull the rectangular, but as soon as I do that, The original rectangular has no circles, the lifted surface has all circles.


#13

I don’t quite see why full thickness don’t work, really it seems they should.

If it’s after the “3d creation” you can draw a Circle and Move/Copy it. Then Push/Pull the first Circle, then “double click” the remaining circles they will be Push/Pulled the same direction and distance as the first one…


#14

After my last edit, I ended up erasing the middle section of the wall altogether and started from scratch. That worked. Thanks for all your help!


#15

I think this has been talked about before and might be a reported bug. I wouldn’t expect this to be normal behaviour, whether it is or not remains to be seen I suppose.


#16

your initial hole including the depth could be made into

a component and copied along as an array too.


#17

I just went back and read this topic again out of curiosity. I noticed that to get the hole to move without skinning over, you have to be careful to select all of its entities. If you miss any, the moved copy will skin over.

Also, I saw what you meant about turning the copy 90 degrees. This happens when you click on the hole and then move the cursor to a different face that is at right-angles to the original face. My gut says that feels like a bug, but perhaps it’s an intentional “feature” since otherwise it is not clear what you meant to have happen. A hole through empty space off the edge of the original face?

hole%20flip


#18

I think it’s an intentional feature that has been like this for as long as I know.
If you have the most simple window (rectangular face) on a block, you can copy that window to any other face on the block like a ‘Glue To’ small face. Like SketchUp is being smart. (*)

In your animation you copy a “not going through” hole which doesn’t skin. The question is: why a copy of a hole (going through the block) does skin. Not a matter of carefuly selecting entities.

(*) even copying a void (four edges) will align to any of the sides of the block, copying the void.


#19

when moving raw geometry it has ‘both’ ‘glue to’ and ‘cut opening’ functionality applied…

geometry needs to conform to the requirements of both, for both to work…

missing edges ‘should’ break ‘cut opening’…

this is deliberate behaviour since at least v2.1…

I see it as the feature it was intended to be…

john


#20

@whiterabbitdesigncompany - I did that, but it didn’t make a difference.