Repeat images when dragging the object

Hi, I got a new laptop to do design with Sketch Up recently.
CPU is i7-8665U, 32GB memory, Intel UHD 620 graphic card

When I drag the model, it will become a repeat stamp,I have to refresh it manually
Reinstall cannot help, it is very annoying.

image

This is probably the issue. You should first go to the Intel site, download their latest drivers for the GPU and install them. If you still have problems, open SketchUp and go to Window>Preferences>OpenGL. change the state of the Fast Feedback setting.

When you installed SketchUp, did you right click on the downloaded installer and choose Run as administrator from the Context menu?

It’s unfortunate that you chose your new computer with an integrated graphics adapter. You would have been better served to get one with a graphics card that is suitable for the job. Maybe it’s not too late to return this one and choose a better machine?

3 Likes

Pretty sure you don’t need to do the steps Dave gave (hey, that rhymes!).

In SketchUp, open Preferences, OpenGL, and check the box next to Use fast feedback.

1 Like

@colin that option doesn’t address the fact that Sketchup doesn’t recommend intergrated Intel Graphic cards.
If the computer was bought to work with sketchup then it is a bad choice and if the option is still available to exchange it for one with a dedicated Nvidia graphic card the OP should look into it.

2 Likes

… and also, computers spend weeks traveling from factories in Asia aboard ship, through ports of entry, aboard train or truck, before they reach retail inventory. They may sit in inventory for more time before being sold and delivered.

By the time the end user starts up the new computer, pretty much all drivers, the OS and any preinstalled software are out of date and need to be updated.

3 Likes

The change in 2019.2, I think, that by default turns off Use fast feedback, was based on the ton of support issues from Surface Pro users, who have a less capable Intel GPU. That then caused a problem for users who have more capable Intel GPUs. It’s almost ironic that a change to fix lesser GPUs caused a problem for more powerful ones.

Also, all MacBook Pro users get by fine with using the Intel GPU, even if the performance isn’t quite as good. So, Intel isn’t the problem, it’s how it is done in Surface Pro that is the problem, and non-Surface Pro users shouldn’t be made to suffer.

Intel drivers are the problem. Apple writes its own drivers.

2 Likes

Thank you.
These steps really help!