Program not running correct

Hi, my sketchup is not running correct, as on picture, any advice. Running on Lenovo E580 intel i3-8130U 4Gig ram, intel UHD Graphics 620

That looks a lot like issues with OpenGL graphics support. Try the following two things: first check Intel’s site and make sure you have the latest driver version for the graphics (do not rely on update from Microsoft, they have a record of pushing out broken OpenGL drivers for Intel graphics). Then try in SketchUp->Preferences->OpenGL uncheck “use fast feedback”.

This is a graphics card/driver problem we’ve seen before. @slbaumgartner has given you good advice. Also make sure that when you installed SketchUp, you right clicked on the downloaded installer and chose Run as administrator from the Context menu. If you didn’t do that, Quit out of SketchUp and do it now. When offered options, choose Repair.

Hi, thanks. when i opened the OpenGL settings in scetchup the the box was already uncheked. so i cheked the box just to try my luck and boom now it works fine. thank you.

Keep in mind that Integrated graphics, especially integrated Intel graphics are well-known to be lacking in adequate OpenGL support. In addition, Windows updates frequently include integrated graphics driver updates that break things. You may see this problem again or other graphics problems again.

Even if ticking the box fixed it, it would be a good idea to check directly with Intel and install their latest drivers. Also make sure SketchUp was installed correctly as I outlined in my previous post.