OpenGL settings "Use fast feedback" results in no image after program crash?

bug

#1

So i was working with a client when all of a sudden SketchUp crashed (like it sometimes does).

I was in a hurry so i simply ignored the bug splat and tried reloading sketchup.

To my (and the clients) horror all i got whas a blank work area without axis, or objects. No error popped up, it just simply did not work.

So i went in to preferanse and turned off maximum texture and anti aliasing. That worked, even though i had an ugly image at least we could see the project.

So i got home and did a full hardware scan, and updated all drivers. Nothing worked. I tried running other 3D programs and they run fine.

In SketchUp i turned of every extension without effect.

So i tried playing around with the settings in sketchup, and found out that turning off “Use fast feedback” resulted in everything working fine again.

WTF happend? and Why isn’t fast feedback working any more?

Running
SketchUp 2018
Windows 10 Pro 64 bit
Intel Core i7-6600U CPU 2.6GHz
Intel HD Graphics 520
GL Version: 4.5.0 - Build 24.30.100.617


#2

Sketcup 2018 checkup Results:

Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card RAM requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!
Success: Graphics card capability tests have passed.

Congratulations, your computer has met all the minimum requirements to run SketchUp 2018.


#3

PassMark Videocard Benchmark — Intel HD Graphics 520
https://www.videocardbenchmark.net/gpu.php?gpu=Intel+HD+520&id=3255


Minimum does not mean Adequate
That SU runs at all on a diminutive integrated GPU is itself somewhat miraculous.


#4

It does work for me! never had any issues whatsoever…
Have to mention that i don’t make very big drawings with high polycount…


#5

W10 is constantly upating drivers in the background sothat a more recent one may have revealed the dodgy OGL support of the intel HD driver. Installing an older driver version and disabling driver updates might help.

If nothing works you can do a fallback to the SU version 2016 w/ less demanding OGL prerequisities. If a SU Pro license (which is req. for commercial use) disabling the product activation of version 2018 and re-activating for version 2016 by contacting the Trimble support might be required.