Removing triangular meshes / internal geometry

export
#1

Hello colleagues,

I am using Sketch Up Make 2017. and then exporting the models in dae. format(which is the only option on Sketch up 2017). When i open the model in cinema 4d, the model is showing triangular meshes and polygon internal geometry. What can i do to only see the surface geometry and remove such meshes.

would converting the files into Sketch up 2018 pro and then exporting in .3ds or .fbx file help in elminating such problems? kindly help/

Thanks!

0 Likes

#2

If you uploaded the SU file we might be able to tell whether the problem lies there.

0 Likes

#3

Hi, Simon. thanks for your reply. The file is too big to be uploaded.

0 Likes

#4

Then you have two other options. One is to upload it to a file sharing facility and send a link. Another is to isolate the part of the drawing causing the problem into a smaller file and upload that.

It’s almost impossible to help if we can’t see what you are seeing in its original form. It’s just inspired guesswork otherwise.

0 Likes

#5

Quick afterthought: if you look at the SU file that you showed a screenshot of and turned on Hidden Lines, what do you see then?

0 Likes

#7

Hey Simon, Here is a screenshot with hidden lines turned on

0 Likes

#8

I’m on my phone but I can’t see any hidden lines at all. Surely there should be some?

0 Likes

#9

‘Hidden Line’ is a Style, ‘Hidden Geometry’ exposes the geometry…

View >> Hidden Geometry

john

0 Likes

#10

converting the files would make no difference Im afraid. this is simply the topology of the mesh, Su does not display much of this. Its a polygonal mesh. If you are exporting to another piece of software this is what you will see unless you control the mesh topology. You might want to think about the structure of the mesh, it looks like the lock is part of the door mesh, separating this away as a separate group will help. The porthole will always cause this kind of triangulation unless you manually draw the geometry you want, the exporter will triangulate the mesh (unless you manually define the triangles where you need to) and will just try and divide the face with the hole in it.

Then when you are in C4D, have a look at the smoothing and see if there is an option to smooth coplanar faces, this will deal with some of this.
The surface normals will look wierd in a render unless you control the mesh topology your self.
Heres a couple of examples…

Here is a render of a face with a circular hole in it, you can see the surface normal and smoothing errors which is basically the same as you have.

in the below screenshot, I have gone into the mesh and (poorly) manually established the topology to manage the surface

This deals with the majority of the problems for the visible parts of my render but the exporter will triangulate any n-gon that isn’t a triangle, see the .dae export shown in Meshlab, you can clearly see my quick manual subdivision and where the exporter has then subsequently triangulated any n-gon.

if you were modelling or dealing in quads the mesh would be much more tidy.

sorry for the sketchy reply but I hope this helps.

cheers

0 Likes

#11

I don’t know Cinema 4D, but there might be an option like “merge coplanar faces” while importing?

0 Likes