LInework Visibility Issue (Sketch Up - 18)

I have been using SU 2017 for years and have just now had to upgrade to SU 2018 due to the SU warehouse removing old SU 17 downloads. Since I have made the switch I can’t find any models for 2018 either, so I export as a Collada file based on other’s advice.

The problem I’m having now is when I import a Collada file to sketch up 18, all linework is visible. All are still displayed even with hidden geometry off. I have no idea what’s going on with this version. This is why I try to stick with a single version, but I must learn newer now.

When you import a file, all edges are visible. If you select all geometry, right click and click Soften/Smooth then slide the slider to the right until those lines disappear.

Collada import also has a “Merge coplanar faces” option that ought to get rid of at least part of the triangulation.