Outlines of some components don't show up when imported?

I’m importing a SketchUp file into another one (I use SketchUp Pro 2019) but when I do this, it only shows the edges of a few components instead of all its faces and edges (see image) in the file that’s been imported. When I open the file by itself it looks normal. I don’t know what’s wrong and would really appreciate some help!
Component outlines

Can you upload the model that shows the problem? And what the import looks like in its own file?

Hard to tell what’s happening without the SU file for at least one of the two.

Is the imported file very large?

The imported file is about 22MB. The files are too big to uploaded.

Might be a case of edges and faces being on separate tags, with visibility turned off for some. Try turning on visibility of all tags to see if the faces appear. If they do you should move all geometry to the same default tag and leave it there.

Monospaced very likely has it right.

You can upload a file that size to Dropbox, OneDrive or a similar File Transfer service, or WeTransfer.

Go to the Layers panel and turn on all the layers.

That didn’t work, all my layers were already on. Here is the assembly file. Here is the model itself.

When I opened the “model itself” file or the “assembly file” in SU 2020, SketchUp found problems to fix. The details reports said that there were numerous component instances using invalid layers. I let SketchUp fix them.

Then I noticed that there are a lot of edges and faces using other than Layer0, so I also fixed that. Then I got what shows in the images below. Are these what you expected?

Yes, that’s what I was looking for! Thank you!

When I opened the files in SU 2020 it didn’t say there were any issues with it. I also tried moving the yellow walkways to the Untagged layer and it didn’t change anything in the assembly file - they still didn’t show up. What am I doing wrong?

Go to Window/Model info/Statistics and click the button Fix Problems.

It said no problems were found?

Regarding the detection of issues on opening, see whether Preferences->General has the “Automatically check models for problems” box checked. You can also force a check at any time via Model Info -> Statistics-> Fix problems.

When a model has a lot of groups or components, it can be quite tedious to check all of them for incorrect tagging (layer usage) on the edges and faces inside the groups or components. I use an extension such as TIG’s layer watcher to get them back to untagged (Layer0) as they should be.

1 Like

Take a look at Preferences->General and see if “Automatically fix problems when they are found” is checked. It may be that SU is silently fixing them when it loads the model. I leave that box unchecked because I like to know if errors have developed in a model. BTW, these kinds of errors reflect bugs in SketchUp’s management of its database in the model, they don’t mean you did something wrong.

The bad usage of tags/layers on edges and faces is probably the cause of not seeing the walkways. I didn’t keep the pre-repair version of the model, so I can’t verify this…

That box is unchecked. I downloaded the extension you mentioned and am going to try that to fix the issue with the layers.

It worked!! Thank you all so much!! :smiley:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.