Imported objects only showing in wireframe


I was just importing some objects (.3ds format) in sketchup. First they showed with faces and textures, but after a second import they only showed in wireframe (although a few faces are still showing). See printscreen attached: the relaxing chair is entirely in wireframe except for some faces in the foot.

As it was correctly imported first, and as the other volumes in the model are showing with faces, does this mean the file is corrupted, or is Sketchup showing it in wireframe because the file is too big? It is weird though that just before, the same file was imported and shown correctly.

Anyway, thanks for any advice on what this problem might be!


It’s hard to say exactly what’s going on with only a screen shot. Might just be that your graphics card is overloaded by all the geometry. Might be something with the imported file. Can you share the file you’re importing and the .skp file?

Hi Dave,

Thanks for the very fast reply. Attached you can find both files.


Filip (178.2 KB)
20211027_Buve_verzekeringen_living.skp (3.7 MB)

When I import the chair into your model I get the faces with no problems.

Even importing it a second time (which you wouldn’t normally after it has been imported once) is no problem. Do the faces show in the attached file?

20211027_Buve_verzekeringen_living with chair.skp (4.0 MB)

By the way, I fixed incorrect tag usage and purged unused stuff from your file.
Screenshot - 1_26_2022 , 8_30_35 AM

Screenshot - 1_26_2022 , 8_30_53 AM

When I open your file, the chair is perfectly with faces indeed, thanks!

Do you know what the problem might be? In the meantime I updated the system to MacOS Monterey and rebooted the whole system. I tried to import again the same object but got wireframe again…

Thanks again,


I tried your files on my Mac Book Pro running SketchUp 2022 on Monterey. Like @DaveR, I had no problem importing that chair into your file, other than needing to set the import units to meters to get it the right size. So far as I am aware, there was no change in .ods import from 2021 to 2022 so I don’t think that is relevant. What model of Mac are you running?

All I can guess is your graphics card couldn’t handle.

What if you first purge unused stuff from your model and then import that file? Any difference?

didn’t work either…

see image attached for the Mac model info

btw I also tried to manually redraw some triangles, that works (see printscreen attached), so it doesn’t seem to be a problem of visualization.


Sorry, I’ll admit I’m at a loss at this point, so just thinking out loud. Sometimes SketchUp will temporarily display an object in wireframe or bounding box while waiting for the GPU to finish. Although the Radeon Pro 580 isn’t the newest, it ought to be able to handle that mesh quickly, particularly with 8GB. There are only two configuration parameters for the .3ds importer: Merge Coplanar Faces and Units, neither of which seems likely to cause this problem - though you could try different combinations to see if that has any effect.

Well guess what, it worked :sunglasses: !!

When importing, I tried different combinations of the ‘coplanar faces’ parameter and the units, and it seems that it does work when I choose ‘meters’ as units 'instead of ‘millimeters’.

I guess in ‘millimeters’ the object might have been to small to properly visualize.

So when importing in ‘millimeters’ and scaling aftewards, it remained wireframe, but when importing directly in ‘meters’, it kept the faces.

Thanks a lot for your help!

That is probably because then the faces are too small for SketchUp to fill. In millimeters the chair is about 1 mm high.

indeed, thanks for the feedback!

That would do it. You showed it at the correct scale in your screen shot so I didn’t think you had imported it in millimeters and scaled it up.