Removing baseboards from doorways

I’m working on the Crown Moulding lesson of the Commercial Interiors course. I’ve selected the floor, copied it into my clipboard, pasted it in place and then try to use the Follow Me tool. As soon as I select the Follow Me icon, the blue line for the perimeter of the floor disappears. Then the baseboard will not be created.

I’ve worked on this for an hour or 2. What am I doing differently from the lesson?

Peter Enns
Baseboards.skp (11.9 MB)
Follow Me Won't Work

It looks like you may be selecting a floor Group or Component instead of an Edge (the path). The profile and the path should be in the same context.

The profile and the floor are in a group. Open the group for edit, select the floor, activate the follow-me tool, then click on the profile. (In the video it isn’t obvious that I start by double-clicking the group to open it for edit. Also, I used a keyboard shortcut to launch the followme tool).


Edit: you have three copies of the floor, causing z-fighting and confusion. You don’t need all three of them!

Do you mean that the floor & the profile should be in the same group?

Peter Enns

That’s often the best way. But what I meant is that you can’t select anything that isn’t inside the current edit context. That was why you couldn’t get follow-me to work: you selected a floor outside the profile group and then tried to select the profile by clicking on the group. But follow-me extrudes a face, not a group. You can’t select that face unless the group is open for edit.

For follow-me there is a trick that @Box likes to use. It relies on two features of SketchUp:

  • the follow-me tool remembers the selected path as soon as it is activated
  • you can use the right-click context menu to open a group or component instance for edit without first activating the selection tool (which would cancel the follow-me)

So, select the path, activate follow-me, right-click on the group and choose “Edit Group”, then click on the profile face. The extruded profile will be in the opened group, even though the remembered path was outside the group. Very useful for your kind of situation, because it avoids the need to copy the floor into the group with the profile.

Baseboards 10.skp (198.3 KB)


I tried to follow your instructions. It still did not work.

I suspect that a big part of the problem is that I have studied many beginner courses over the past several months. This course (Commercial Interiors) is the first intermediate course I’ve started.

When I go to the lesson on Follow Me, I got confused. It just was not working for me. So, I reached out to the forum and that isn’t working for me either.

I don’t quite understand your specialized vocabulary, I guess.

In the attached file I thought I made the profile part of the wall. I’m under the impression that I can copy the floor perimeter and than click on Paste in Place to have a selected series of lines for the profile to follow.

Do you have any further words of wisdom & instruction for me?

Peter Enns

Click in sequence on the scenes tabs of this SU file for ideas.

Baseboards 2 - JL - 2024-03-20.skp (349.8 KB)

Hello SketchUp Sage,

I’m having something really weird going on.

When I was trying to make the baseboards, it was just hit & miss. Sometimes they would be created with Follow Me but usually they would not.

Today I was trying to get to the bottom of that problem. I began watching a “how to” Follow Me YouTube video.

Doing what the instructor said, I would draw and select a path, it would turn blue, I would turn on the Follow Me tool and that path would become unselected. It would be black and the Follow Me tool would not be able to create anything.

Then, after a few tries, some sort of memory was suddenly turned on. I would select a path, it would turn blue, then I’d select the Follow Me tool and the path would return to black. BUT, a memory would automatically be turned on and the Follow Me tool would work perfectly.

And it’s continuing to work perfectly.

Do you have any insight into this? Why would the “memory” have been turned off for the past several days and then suddenly turn on? It’s a real mystery to me.

Peter Enns

this is no “turned on memory” thing. it’s how the tool works.

  • you select the path. it becomes blue.
  • then you click on follow me, the path is now back to black. but sketchup knows what the path is, it now expects a face.
  • and you click on the face, you get a 3d thing.

There are 2 main reasons why it didn’t work for you :

  • either you did some extra clicks. maybe you selected, clicked on follow me, then clicked somewhere before clicking on the face
  • judging from your 40 previous posts, I’ll say the face was in a group, ie. a different context. you selected the path, clicked on follow me, and then clicked on the group containing the face. and not the face itself.

a group is like a ziplock bag. you can see what’s inside, but you can’t access it directly. if sketchup expects you to click on a face, then you have to click on a face, not on a group containing a face. because clicking on a group is different.

1 Like