Re-rendering of uploaded models does not complete

Greetings. I’m attempting to upload a model created in Sketchup Free into the 3D Warehouse, but the “Re-rendering” message after the upload never completes. The model is not particularly complex, but it does have two scenes. For my first attempt last night, I downloaded the model from Sketchup Free in 2019 format. That model still had not completed this morning (about 12 hours later).

This morning, I tried another Sketchup Free download in 2017 format, then tried to upload that. That has been almost an hour, and it is still showing the “Sprinkling some magic” re-rendering message. Here is the most recent model:

What is the issue here? Scenes? Sketchup model version? Suggestions are appreciated.

Here is a recent topic that might be the same thing:

The solution there was to delete the model and upload it again.

Thank you, Colin. I deleted the first model, and the one above is the second attempt. Strangely, it appears to render correctly above, but not when one accesses the model page directly. I will try deleting this model and uploading again.