3D Warehouse won't render

I finished a new project today in SketchUp 2017 but after uploading it to the 3D Warehouse, the 3D Warehouse fails to render it. This problem has re-occurred in both Safari and Google Chrome, also after deleting and reuploading the model. It has been like this the whole day:

Is there an issue with my model or is there server maintenance of some sort going on?

Hey @MrGtheSheep, we’re currently investigating the issue and hope to have it back up and running shortly.


Thanks for the heads-up @MrGtheSheep. We’re looking into it.


When I replace certain models with updated ones other than reuploading the same model, I often keep getting messages saying “Failed to render” no matter how many times I reupload the same model. It never happened to me before until now so why is it so? Sometimes it took too long to finish the render compared to before, it’s just stuck in the “SPRINKLING SOME MAGIC” no matter what the size of model is.

I’ve been uploading many models without such problem until now. I’m also using Sketchup 2017.

Some of my models keep getting stuck in ‘‘SPRINKLING SOME MAGIC’’. I tried waiting for like 2 hours and still is the same thing.

Like these. I hope whatever’s causing this will be fixed soon as possible.

The 3D warehouse no longer supports the 2017 and 2018 versions. It only supports the last 3 active versions of SketchUp. You can upload through your web browser.

1 Like

Already tried that, but the waiting time is still too long.

What’s the rush?

I just uploaded this one to the 3D Warehouse and it was rendered in about 30 seconds.

@mhkt9930 -
I fully understand your frustration. I had a model that went from being sprinkled with magic (it took quite some time - WAY longer than 30 seconds), to appearing to have eventually rendered successfully, to later on when apparently the process decided all that magic didn’t work afterall and advised that rendering had failed.

I uploaded the model again, and went about doing other things while all the necessary magic was being sprinkled. Later, I started signing out of stuff and discovered my model was still getting some magic. Signed out anyway, closed the browser and shut down the ol’ computer. Next day, magic was STILL being flung all over the place. Though I do not know if they were successful or not, stats showed three downloads.

After a couple more attempts, my model finally rendered. Then I discovered I forgot something. Went to the file, made my edits and uploaded the new file. Took three attempts over a few hours before all was well.

Though I’ve seen several complaints about this in the past months, this is also the first time for me experiencing this issue. That sorta makes me think it’s getting worse.

NOTE: My uploads are via my browser… not inside of SU. I have never used SU to upload to the Warehouse. I would think that may be an indication that SU, no matter the version, is not the issue.

1 Like