.rbe extensions not loading

For many years there have been largely unresolved complaints about .rbe files not loading. The normal suspects chime in with nonsense about reinstalling as an Admin and it never seems to help this issue. I don’t think I’ve every seen anyone who has found a working solution. The solution always seems to be “your Windows profile is corrupt”, reload Windows. Not in any way a solution in my view.

However, here’s an idea that people can perhaps help test…On my Windows profile, the one that doesn’t work, the .rb and .rbe files are selected to open with Notepad++. Could this be the problem? Is SketchUp expecting the Ruby interpreter to open these file types by default?

Can someone who can load .rbe files check this setting in “Choose default application by file type” in Windows 10 Settings.


Setting the basic RB files to open with Notepad++ is fine - that’s what I have set up…
BUT RBE files don’t ‘open’ with anything.
They are encrypted files that only SketchUp can ‘read’…

The RBE files not getting loaded and throwing up error messages is because SketchUp is failing to read that file’s contents.
The file-type associations have no bearing on the problem [IMHO]…
This error could be because your SketchUp installation has improper permissions set up - hence the urging to install the Downloaded SketchUp installer exe file using ‘Run as administrator’ etc, then choose ‘Repair’ as needed…
But sometimes users do have a corrupted Windows user-account which leads to similar problems…

1 Like

If the user-account is “corrupt” what exactly is the problem? It must be fixable if someone could explain what the corruption is.

Might be able to help - I know he’s tried to help fix similar issues…

We have had reports of this going back a few years. The earlier reports seemed to be tied to special characters in the system user name, but more recent reports were where the user name was using ordinary Roman characters.

In one case the person having the problem cloned his user account, and the clone worked even though the original didn’t. But the clone may have had a different name.

If you would be willing to try something, copy and paste this into File Explorer, and when you get to the folder copy the full path into your next reply:


I get this from %AppData%

C:\Users\Firstname Surname\AppData\Roaming

I’ve replaced my real profile name with “Firstname Surname” for privacy.

Could you send @colin a private-message to show your actual “Firstname Surname” - as he’s interested in how it’s made up…
I suspect it won’t contain ‘special-characters’ [i.e. NOT A-Za-Z0-9 and some basic punctuation like _ and - etc], but the space [if any] might be contributing ??

There are no special characters, just normal upper/lowercase letters (I’m a programmer and know the difference) but there is a space between the first and last name. Interestingly, I created another account (called simply Test1) which contained no spaces and it works ok.

Thanks, but PM @colin anyway…
Windows recommends no spaces in user-account names… BUT I don’t think that’s the problem…
There are many posts on this, with fixes etc…

It’s also important to remember this “Firstname Lastname” account (with a space) used to work until a few months ago. Something updated and caused the problem. Of course the challenge is working out what caused the “corruption” - or perhaps intolerance of a space in a username?

Maybe a Windows update?

Indeed, it could be a Windows update, or perhaps installation of another application which might have changed a registry value, path details etc…The bottom line is something stopped this account from working. I’d like to find the reason as it appears to be a common problem that has never been solved.

No need to give your name, I am quite sure that it is as straightforward as Firstname Surname. It would be interesting to make a profile that actually is Firstname Surname, and see if it fails.

let me stress again…the account used to work and successfully load the .rbe files. Something then changed and it stopped working. Are you able to ask the developers to check it out?