Quality of lines in LO

Hello people.

My name is Vasilis and I am from Greece so excuse my English. I am a freelance interior designer.
I started learning SU one year ago and I am at a good level right now. I can proper design 3D models at the moment.

I have one question though. As I moved to layout to arrange my plan views and my 3D views I noticed that lines aren’t in high quality. The are not straight as they are in SU. After some search, I noticed that I had to setup LO to a higher resolution and I checked the difference between raster/vector/hybrid but still the quality of the lines aren’t good enough for displaying or printing.

Is this a fixed senario? Is this how layout “translates” SU lines?

It’s quite unuseful for printing perspective 3D views

You should see SketchUp edges as crisp vector linework if you render the viewports as Vector or Hybrid. Display quality may be set low but export quality should be fine.

Can you share a LayOut file that shows the issue you are seeing?

Shall I share an actual LO file or a pdf export?

Both would be great.

LO.layout (5.2 MB) PDF.pdf (992.1 KB)

Here they are. On my monitor there is quite a difference in quality from SU to LO

Only when I double click to edit the viewport in LO, I get the same quality as SU.

You shouldn’t double click to edit the viewport in LO.

Your PDF looks good on my computer. The display resolution in LO won’t be as good. That’s just done for resource management.

For me the problem seems to be in Adobe Acrobat. At a small scale its screen display doesn’t seem to be the prettiest
image
But if I zoom in , I see that everything is sharp.

1 Like

This is a zoom in on a pdf export in Microsoft Edge. Its exactly the same if I zoom in LO.
And without zooming in I can still see that in both apps

It’s hard to say what you have in your model. For example it looks like a column beyond is showing through a face, and that would not be normal, unless the face is translucent. There’s a problem that LO hybrid can’t show edges through translucent surfaces.

I think the front blue surface edge may look that way because it is formed by the face color in SU, and not a visible edge. The face colors (“materials”) are bit map only, and the only thing you can do is export at the highest resolution. You can retouch that edge after the output from LO. You can add a visible edge in SU (and control its thickness through some workarounds in LO) but it will be black and not blue. I usually find that these resolution problems are not an issue at normal viewing zoom or prints.

The tiny stair-steps circled in red are “jaggies”, a type of aliasing artifact that is inherent in raster displays. I don’t know if the PDF generation process can be customized to enable “anti-aliasing” which is a technique of gradually blending the adjacent colors along an edge to effectively blur the stair-steps.

As has been pointed out, the “jaggies” you highlight are normal in raster images. You have no visible edges in those places to render as vector.

Ok got it. If there is hidden geometry like lines, I get these artifacts on the borders with bitmaps. I unhide the lines on the blue surfaces and the problem got away. So I am restricted in visible geometry for not getting these type of artifacts.

Another question. Both in LO and in PDF when I zoom in, some lines are thicker than others. Why is that?

The line thickness is because you have Profile edges set to something larger than 1 in the SketchUp style.

1 Like

Sorry for the inconvenience. I changed the style but everything disappeared except the lines. It was set at “Simple Style”. What should Ι choose if I want to maintain my textures?

You chose a style that doesn’t display texture. It uses the Hidden Line face style. You can apply that style in SketchUp and edit it to change it to use Shaded with Textures for the face style.

The native Straight Lines style.
Screenshot - 2_9_2021 , 3_03_36 PM

Face style changed to Shaded with Textures.
Screenshot - 2_9_2021 , 3_03_51 PM

Keep in mind that the lines in these styles are raster images and will not render as Vector lines in LayOut.

1 Like

Goodmorning guys.

Ok so I changed my style in SU to Straight lines 01pix with shaded using textures. My lines are all in the same thickness in LO now but I see raster artifacts. Is this what you was talking about above that lines are raster images in this style?

Anyway can you assist me on what are the best settings to use in SU or LO for printing?

I spend last night 3 hours searching online for info about styles and best settings for printing but couldn’t find anything. I need the best possible printing quality.

You are still using a “sketchy edges” style. Select one of the “Default styles” and modify the edge and profile thicknesses to suit.

2 Likes

In SU?
Can you guide me through please?

Styles/Default Styles/Architectural Design Style / Edit ???

Hello people.
I managed to come around with LO.
I choose from SU the simple style preset with edge setting profile set to 1. Now my lines in LO are equal in thickness. But now the problem is that when I have profile set to 2 I don’t get the jaggies but I have the unequal thickness in lines. When I set the style edge profile to 1 I get equal lines but jaggies. Is there a solution to this?


Edge style profile set to 1 (equal lines but jaggies)