PushPull tool will not follow curve or go around corners

followme

#1

Just downloaded Make 2017 with the understanding that a 30 day full trial version of Pro was part of the download. I have used Pro and Make since its introduction. I currently do not have a full version available to me. Make has been sufficient for at home use. I upgrade make every time an upgrade is available. Here is the problem… I cannot get the push/pull tool to follow a curve or go around corners using any of the methods available to achieve this.

I am certain it is not a hardware issue. I have installed and uninstalled Make 2017 several times. I have read all the topics related to this issue.

What, going on?


#2

Push/Pull has never ever extruded around a curve in any version of Sketchup. Follow Me does, though.

Post an example SKP file that shows what you are attempting to do so we can help you get it right.


#3

terrible brain cramp. Thank you for your reply


#4

I am a beginner with the same issue. I’m confused because I am pretty sure that I had produced the wing cross section by using the “push/pull” tool. Now it tells me that I cannot do so, and in the answer above, I read that I cannot have created the cross section in that manner. Can anyone help me extend this wing cross section outward, away from the fuselage? Thanks in advance.Oscar v045.skp (570.9 KB)


#5

I just figured it out: the “move, stretch, copy, and array” tool helped me move it!


#6

turn on hidden geometry and can see why it failed…

it’s always best to fix these issues as you progress, so the don’t bite you latter…

john


#7

Corroborating what @john_drivenupthewall said, here’s the front part of the wing with hidden edges visible. It isn’t flat!

17%20AM


#8

Thanks! I just turned on that view. I’m cleaning up that spot now (I hope) ! :grinning:


#9

Is there some reason that the “move, stretch, copy, and array” tool won’t allow me to make one vertex join another? I tried, but it just won’t jump to it. I can only move vertex 1 along one axis. What could I be overlooking? Oscar v045.skp (618.8 KB)

:thinking:


#10

With nothing selected but the ‘Move’ tool you can hover over > click (and hold down Lmouse button) > and drag a vertex to drop it on another vertex.
So click on vertext 1 (hold down the Lmouse button) and drag it towards vertex 2.

I know, it’s an odd ay of selecting something, unlike selecting real entities like an edge, face or a group.


#11

That worked, thanks! I also discovered while zooming in very close that I had stray lines that might have been preventing me from snapping to vertex 2. :grin:


#12

You don’t need to drag. With nothing selected you can click a vertex and move it. You can move along a direction with a precise measurement. If your move commands are stuck into a direction/plane hit Alt key. If you want to move on determined direction of the x,y and z planes use the right, left and up arrow. For using directions/planes of existing geometry, down arrow. To lock any inference shift.


#13

Yeah, it can be necessary to zoom in pretty close to get the inference snap you want when the model has a lot going on nearby. That’s one of the frequent points raised when people request ability to turn off inference snaps or choose which kinds are active.


#14

Thanks for the helpful shortcuts! :grin:


#15

Dragging works with all settings. So there won’t be any confusion in being able to move a vertex.
Click-move-click works in only in that specific setting. And it happens to be the one I dislike.