PushPull leaves lines or sides or won't push

Canopy.skp (2.3 MB) I have 2",2",8’ canopy rafters that on some of them I can’t PP on certain sides without issues. If I pull it, it will leave a line at the starting point and if I delete the line it deletes the side. Or if I try to shorten the stick it won’t allow it beyond the 0 offset. I’ve redrawn it multiple times and changed graphic cards. When it does allow making the stick shorter after redrawing, it always will not shorten one side. I’ve set the axis to the group because the rafters are in an upward fan shape. I’ve deleted all guides.

I’ve been through the complete beginner course and tried to find the answer to the problem online but after 3 days of fighting this kind of problem over and over again I am at my wits end and need help. I really don’t want to have to make another fresh start on this project. Everything else is in groups so they shouldn’t be interfering. Thanks

We can only guess at where the problem is until you attach the model.

Box is right. If you share the SketchUp file we won’t have to guess.

I’ll make one guess, though. What you describe is typical when the face being extruded is not perpendicular to the adjoining face. The edge you are seeing is required to support the faces on either side. Push/Pull acts perpendicular to the face being extruded.

I just uploaded one. The problem is in the right rafter which is now exploded. Thanks

The problem is in the right rafter which is now exploded. Thanks

As I guessed.

Once the end is squared up with the length, you get what you expect.

Does this happen because I make the rafters in place at an angle? It is too hard to make them and then try to drag and angle them into position.

It’s not specifically because you model the rafters off axis. It’s because you apparently didn’t draw a rectangle for the initial face. You have to watch the inferencing.

My recommendation normally is to model parts in place as much as possible. Coupled with the inferencing, modeling place should result in fewer errors and requires less information input.

That said, it shouldn’t be difficult to move and rotate things into place with precision. It requires learning to use the Move and Rotate tools correctly, though, and it takes practice.

I thought I was always following the right angle inferencing lines but apparently I will have to zoom real close to be sure. Thank you immensely for solving this problem for me!!!

Good luck. It’ll come with practice

You can also set the axis of any geometry modeled on an angle so the axis is square with the geometry. That way when you model it you are not relying on inferencing but blue, red and green axis. They just need to be a group or component.

3 Likes

There’s also a potential problem with the way layers are being used. To repeat the mantra once more, only groups or components should be assigned a layer. All raw geometry (edges and faces) should be on the default layer 0.

Shep

I didn’t even look at Layers but Shep has a good point.

I think the problem has something to do with the axis though I’ve tried to set the axis many times and have it end up square with the rectangle but it always goes back to being a little skewed. It doesn’t seem to matter if I redraw from scratch or from all but one deleted line as I just did again on this upload. I followed the inference lines exactly and still the angle is .2 off and when I group it the bounding box is skewed. Canopy.skp (2.3 MB)

The corner is still obtuse in this latest model. It measure as at about 90.232°. You can also see an issue with the shape of the geometry when you look at the bounding box. The edges of the bounding box are always parallel to each other.

What angle to you want that thing to be at relative to the rails between the legs? Should it be 45°?

And one other thing. The posts have been drawn on the diagonal so their bounding boxes are skewed.

It would be better to have the bounding boxes aligned with the geometry. They’ll be easier to work with and if you later want to generate any sort of cutlist or other report, as they are now they’d give you erroneous dimensions.

You reset the axis after you group geometry.

  1. Create geometry.
  2. Make Group
  3. Right Click or double click on group to edit.
  4. Right click on any of the axis lines, select place
  5. Choose your alignment of each axis.

Or the faster way is to create your component or group on axis, then simply rotate the group or compinent into position.

1 Like

Why does it keep doing that? 45 degrees to the rails. I’ve gone over that angle many times., why does it keep shifting??? It seems like I’m spend all my time rechecking and correcting stuff. All those rafter angles should be perfect.

I’m not sure what you are doing incorrectly. This shouldn’t be that difficult. Maybe if you reset the axes, draw the rafter aligned to the axes and rotate it into place you’ll have better luck.

Try this:

Draw a square on top of the rail to 1-1/2 x 1-1/2 in. Use Push/Pull to extrude it to length.

Create a component.

Copy the rafter to the other end.

Rotate the component 45°

Repeat at the other end.

I expect you will find it easier to model with precision if you turn off Length Snapping in Model Info>Units and although I wouldn’t work to 1/64th in in real life, I prefer to set Display Precision as high as it will go for the selected units when I’m modeling. Makes it easier to keep on top of dimensions.

That’s what I’ve been doing, aligning it after grouping. I think I also triple clicked then used the alignment tool but I just now did it the way you said but the bounding box is still skewed.

You are not following the steps correctly.

Make sure you are in the group or component and then place the alignment inside the open group/component

If you do this correctly the bounding box has no choice but to follow the geometry so you get the same affect as creating the group or component flat on the red / green axis of the main file.

2 Likes