Complete Newbie - can't push original face of component? (limit reached)

Hi all

Just started using Sketchup for the first time following some quite good tutorials on YT. Anyway I was designing some birdsmouthed rafters for a pergola extension and I wanted the intermediate one’s to be 100mm x 50mm as opposed to the ends being 200mm x 50mm. So I duplicated and use the multiply command to fill in the additional rafters from the end ones - very happy - that worked. Made the two end ones unique. But when I tried to push the bottom of the inside rafters up to make them 100 high rather than 200 it said limit reached.

Is this a limitation of the program - that you can’t adjust the original face into negative? Or as I suspect just a lack of knowledge…

I hope I explained that OK and I have no idea how to share a free project with the forum - doesn’t seem like you can download the SKP file.

(The rafters sit on a 5deg angle so I got around it by establishing the midpoint from the side face, tracing the shape - bang on 100mm and cutting out in that direction… but still would like to know if I’m missing something obvious)

This.

If the face you are pushing runs into a face on the end of side, it’ll stop.

You can share your .skp file in the forum unless it’s really huge. Try dragging the file into a reply in your thread. If it’s too large to upload, upload it to Drop Box and share the link.

Thanks Dave.

You can’t download the .skp file from the free version AFAIK, so no way of dragging and dropping. I didn’t see a share option either when right clicking. Tried to the desktop no go.

Use the folder Icon top left and select Download from the list.

To illustrate Box’s instruction:
Screenshot - 4_21_2020 , 5_32_01 PM

And I moved this to the correct category.

thanks - worked it out. I was looking in the project manager where I expected it to be…doh!

Pergola Extension.skp (272.1 KB)

Still super slow on this as I learn how to snap things to planes etc. Still this little project was a good one to start on.

The reason you can’t use Push/Pull to make the “Inside Rafter” component thinner is because the end isn’t flat. The diagonal required to created the faces indicates the edges aren’t coplanar. If you fix that end, you could change the thickness.

Actually the easiest thing would likely be to erase everything but one long face and use Push/Pull to extrude it to the desired thickness.

Triple click with Select to select all of the geometry.
Hold Shift and double click on the top face to deselect the face and its bounding edges.
Hit Delete.
Get the Push/Pull tool § and push the face to create the desired thickness.

Hi Dave

Not quite what I was trying to do. I was trying to transform the wider (200mm) end rafters into the intermediate rafters that are 100mm in that dimension (the 50mm dimension didn’t change). When I tried to push up on the base, Sketchup would let me so I cut it out from the side instead to create the internal rafters. It’s probably that whole coplanar thing as the rafters are cut on 5 deg angle to create the slope for the roof.

thanks so much - I’m learning all the time. Still a long way to go.

John

It’s the same problem though. The ends of the rafter aren’t square to the face you are pushing.

If you want the ends to be angled like that, draw a line on the long face where you’d rip the board and use Push/Pull to push away the waste.

That’s what I did…

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.