Push/Pull Tool misbehaving


#1

I’ve recently noticed my Push/Pull tool is misbehaving. When I enter a value in the value box, SU freaks out for a few seconds (stops responding) then does some random Push/Pull length but push/pull tool is still active, but then if I enter a value snaps to the length value entered. But then I can’t undo it.


#2

I think you attached the wrong video.


#3

I know, I’m fixing but right file is too big. I’ll delete and re-post. Cheers Box.
Doh, tried again, still to large a file! Might have to do YouTube link.
https://youtu.be/Fk3J2AB9kXU


#4

Maybe it has something to do with the file so I’ve attached it if you want to try it. The section profile is for a steel perlin C-Section that I imported as a dwg file, selected all lines, used smustard weld to make curve, traced over end line to make face then save as component. When I drag in as component, I explode it, make it a group then push/pull it to required length.
c200-20h.skp (22.5 KB)


#5


No problems extruding it here. Are you sure you aren’t hitting some hidden geometry or something else?

Why do you explode it and make it a group? That’s unneeded.


#6

Why I exploded/grouped is normally I’d make unique for different lengths etc, but I was just mucking around with push pull to see what was causing the issue. Just told exactly what I did in case you wanted to replicate it. I thought it may have been the model file I was working on when it happened, so push/pulled it in a new file to see, and still get the issue (so hidden geometry shouldn’t exist). Although it seems to mainly happen on faces with complex edges (curves). If I push/pull a simple rectangle face etc it works fine. I’ll go and see if it is still doing it again. Try a few different scenarios. I’ll update soon.


#7

Did a retest and still getting an issue. It becomes unresponsive when i enter a push/pull value, then it doesn’t complete the push/pull, then it spacks out and won’t work at all, no matter what value I enter. It still push/pulls but the value box doesn’t work.
Push/Pull retest 1


#8

Hmmm… This makes me wonder if you have SketchUp installed correctly. Bizarre behavior like that has been attributed to incorrect installation before. When you installed SketchUp, did you right click on the installer and choose Run as administrator? That is required for correct installation. Since you’ve nothing to lose, you could try repairing the installation but selecting Run as administrator followed by the Repair option.


#9

Went to repair (Windows10 Settings > Programs & Features > SketchUp2017> Repair) and get the following windows pop up.


When I click Cancel, this comes up
SketchUp2017_source_repair
Where is the “SketchUp2017x64msi” installation package meant to be exactly? I can’t find it to repair.


#10

If I hit OK on the Windows Installer window, I get this pop up (bottom window)
SketchUp2017_path_repair


#11

What @DaveR means is, install SketchUp and choose ‘Repair’.

These are the steps…

  • Close SketchUp.
  • Find the SketchUp installer .exe file - assuming you downloaded it in the default way it should be in your Downloads folder…
  • Select its icon and right-click > context-menu > ‘Run as administrator’…
  • When prompted choose ‘Repair’.
  • Restart SketchUp and see if it helped…

Installing SketchUp in any other way will cause unpredictable flakiness down the line.
So do NOT double-click on the installer’s icon, and do NOT choose to simply ‘Run’ it.
Being the admin, or having admin powers is NOT the same as using ‘Run as administrator’ !

I guess the error messages you got were because you chose Control Panel > Programs and Features, selected SketchUp and chose ‘Repair’, this would run in the same mode as the initial installation - so would not fix things if it had originally been done incorrectly.
The missing file error is because the main installer .exe extracts its .msi file into a your Temp folder and runs it from there.
It you have cleaned up your system since the installation the Temp folder was probably emptied, hence the missing file message. Or not having initially installed it properly perhaps folder/file permissions are screwed up !


#12

Well, I reinstalled, then I right-clicked > context menu > ‘Run as administrator’ > Repair. Didn’t help.
It seems to only do it on that c section component or similar components (imported .dwg sections maybe?). I tried a little experiment, exploded the component edge, then deleted the arcs (corners) and replaced with straight edges (right angle) and push/pull to entered value…works fine. If I then drag in that component and try to push pull it, SU stops responding for a few seconds then the value box doesn’t work (same as in video). Seems it doesn’t like the small curves in that component or something. I even tried scaling it up x 10 and that didn’t seem to help either. I’ve attach the original dwg file, not sure if any use but thought can’t hurt. This is getting frustrating.
c200-20h.dwg (4.2 KB)


#13

I have no trouble with it, imported in metres, millimetres and with retain origin.
All versions work for me with no issues.


#14

I think there’s something going on with your computer or possibly some extension that you have but I don’t.

I imported your DWG file with units set to millimeters. That makes the wall of the channel 2 mm and the innerarc radius 5mm. I have no trouble with Push/Pull or the Measurements box.


#15

can you upload the .skp component? (right click, save as)


#16

Already have. See earlier post


#17

I disabled all my extensions (even dynamic components), so exploded it and push pull on that entity is still playing up. Not sure what to do next. Starting to wonder if it’s a memory issue or something else. Would there be some way of monitoring my computers performance whilst push/pulling it to see if it is related to SU or something else?


#18

Well, you can open the Task Manager and click on the Performance tab. You’d need to either shrink the SketchUp window or put the Tansk Manager on a separate screen to be able to watch it while extruding in SketchUp.


#19

It isn’t quite clear to me from this description whether you reinstalled first, THEN chose Run as Administrator/Repair.

You might find it worth one more try, first uninstalling completely from Apps and features/Sketchup then click Uninstall.

Then try a new installation as described above.

I’ve seen a few reports on the forum where running Repair didn’t fix a problem, but a complete uninstall, restart computer, then reinstall using Run as Administrator did clear things up.

Like earlier respondents, I had no trouble importing the DWG file, creating a face from the edges by drawing a line in SU, then pushpull worked without issue.


#20

Well, after a couple of hours mucking around I’ve isolated the problem. It appears to be TIG Layerwatcher! The c200-20h line work is not on Layer 0. The component is, but the internal entities aren’t.

I disabled all my extensions one by one then re-enabled them one by one, testing my c200-20h push pull file until I finally isolated TIG Layerwatcher. I uninstalled it and the problem goes away. So I then I checked my test file and the internal part of the component was on Layer “c200-20h”, which is created when I imported the original dwg file. So I corrected it by opening the component > select all > placed on Layer 0 > closed out of component > selected component & placed it on Layer c200-20h…and SORTED!

Feel free to replicate and see if the same happens. Thanks for all the help & support. I think I have another Doh book addition…Keep all line work & faces on Layer 0…doh!