Push-Pull behaving oddly

I’m using v2020 [20.2.272] on an MBP with Intel Iris Plus Graphics 1536 MB
Push-Pull is behaving weirdly.

  • If I make a rectangle on the ground, then I extrude it upward with PP, then click to stop extruding, everything works fine.

  • But now, if I type a dimension and hit Return, it collapses into a 2D rectangle again.

I can beat this by snapping PP to an edge or another object, but I’d like to be able to type the dimensions.

Any ideas? thanks in advance

oop. that’s 20.2.171 sorry

Try pulling up but not clicking the second time. Just let go of the mouse and type the dimension.

Please complete your forum profile with that info along with the OS and graphics card. And why not update to 2020.2?

Yes, that hasn’t worked. Just tried again but no beans.
thanks though

It works for me just fine. Are you clicking in the measurements window?

Yes. I’ve been using SketchUp for a long while; this is the first it’s happened. I’m having similar problems with the Scale tool . . . hmm. Something’s up. Thanks for the help.

maybe the rectangle is MUCH bigger than the entered height?

Do you perhaps have smart quotes enabled in Settings->Keyboard->Text? That will mess up entering values for foot+inch units.

It turns out possibly to have been related to BitDefender. Not sure, but after installing Big Sur I noticed my MBP was heating up. I use ‘Macs Fan Control’ thermal monitoring app. So I checked Activity Monitor to see what caused the processing overhead, and it was BDUpdDaemon from BitDefender. BitDefender is a good app, but a few others have had this problem with overheating or slowing.

They have a nice Uninstaller (whew! It’s in the application folder; there are tedious ways to do this manually, but the uninstaller works like magic). I rebooted, and SketchUp worked very well, almost restored.

I still have some trouble with Push-Pull actions collapsing into 2D objects after I type in dimension. A brief report came up on the screen at one point but was ephemeral – it said something like “VCB error caused operation to fail”. something like that.

1 Like