Push pull tool keeps saying offset limit

Never ran into this issue before. I made a box, and i try to push pull it through another object, like i have done many times, and i keep getting this offset limit error. never seen this error before either.

i have modeled this shape before and exact project before and this is the first time i have encountered this

thanks

This is normal. Push/Pull is bumping into other geometry that is in the same context as the surface you are moving. If you have not noticed this in the past it is because the object you were push/pulling past was in a separate context, ie it was contained in a separate group or component. If the obstruction is contained in it’s own component or group then it is not seen as an obstacle because the two surfaces are not in the same context.

You can tell if an object is has been made a group or component by clicking on it and seeing if it has a bounding box. Best practice is to make groups or components out of all separate pieces of your model.

i model in groups or components all the time haha and thats what is throwing me off. it should be doing exactly what you show but it aint.

Is the obstruction already a separate group or component? Can you upload the model here in a reply?

Is there an edge or hole behind the obstruction on the other surface that you are running into?

the obstruction is its own group. i even tried making the back wall, bottom wall, and the obstruction all in one group. then the new geometry was just its own and it still had issues. i cant upload the object. i deleted and restarted. i did have to do a work around by making the other piece on its own, then move into place.

i have made very very complicated engines, 3d printer parts, etc, and i always model in place, and never had this issue.

im going to restart the pc and sketchup and try again. my machine has been on for over a month solid

Post the model, I’m sure there is a reason that is part of the model. Hidden geometry on the wall?

If that thing is a group, hide it so you can see what’s under it. There must be something else the face is colliding with to stop Push/Pull.

1 Like

i hid it many time and there was no extra geometry:) sometimes my pc and sketchup do this weird stuff.

once i restart the pc and sketchup, after im done with a small project. ill let you know if i get it to work.

after restarting everything, sketchup now works the way it should. for whatever reason, no matter what i did, it would not work. now it does. super strange. thanks

There are various things that will cause this, hidden/soft edges, overlapping geometry, misaligned faces, broken path etc etc
Tapping ctrl will normally allow you to pass through the issue by creating a new face, this face can help you find the cause.
Offset limit

Interesting. Maybe my group was messed up, ie, i disnt have one of the lines in the group. Ctrl with push pull is a great feature. I use it alot, but when i saw this happen, which is the firat for me, i was bewildered haha. But now it works. When i did check for hidden geometry, it disnt show any, so maybe it was a piece of the group i missed

You often can’t tell, or recollect, how many times a group has been made or components within that group have been. When I run into the issue you describe I’ll select the part I’m struggling with and “explode” it as many times as it takes to free up the object that’s not cooperating