Push-Pull just moves the surface?

A simple square drawn at his feet and the push-pull to drag it up. It should enclose him in a box. I also happen to have from V7 all the way to the latest V15 and the same thing happens in all versions.

If the surface is part of a box or a 3d entity already, then I can push-pull normally.

Anyone any ideas??

Does a computer restart change this?

restarted, rolled-back all MS updates from today and re-started, un-installed and re-started, re-installed and re-started… unfortunately nothing I’ve done has fixed it yet.

And I have now found out that the paint bucket never actually changes to the bucket: it always pipettes the texture it’s over and I can’t click to apply the texture. (The icon doesn’t even change) ??

Edit: I’ve also found that even with an existing box, it actually “moves” the selected surface rather than push-pulling it. If I sub-divide a box’s face and try using the tool on one bit, that bit moves, constrained perpendicular to it’s starting plane (still attached to the rest of the object) rather than extruding.

It sounds like your alt key is stuck.

3 Likes

I was going to reply, it sounds like events are being misprocessed for some reason. A stuck key would do that, as @Box suggests.

Unfortunately it’s not simply a sticky key; I can use the ‘alt’ key to navigate the menu and to ‘alt-tab’ between applications. Something catching mouse events and misprocessing sounds about right tho…

Just for giggles, you could start the ease of use On Screen Keyboard and see if the alt keys are highlighted.

I remembered this thread on Sketchucation, apparently solved by re-installing the video driver.

Push/Pull problem solved

Shep

on-screen keyboard works as I expect and only shows when I press it; just about to remove the graphics drivers and try that…

Removed the drivers and it works!
Now to try and get drivers that don’t cause the same thing again.

Thanks for everyone’s input :smile:

Fix your drawing! Steve looks like he may not be able to breathe!

1 Like

6 Likes

I have the same stupid problem
I think this was caused by a recent Windows Update…
Windows 7 x63, SKUP 2014, Geforce210 video card.
Reinstalling the drivers does not solve the problem
Same symptoms like above… push/pull not working and the paint bucket when select turns into a color pick-up tool

BTW is this a forum issue?

1 Like

Sorry I can’t help with the drivers issue! But regarding your forum question: NO, that is working as intended (though perhaps not obvious until you think about it). It is a scrollbar hint saying that you are viewing the 12th of 13 posts in a topic in which the last prior post was in March 2015.

OK thanks for the clarification

THis is interesting…if I select the color tool (bucket) this turns into a color picker (pipette) automatically
If I press Alt the tool turns into a bucket but if I move the mouse the tool turns back into a pipette.

Update: I installed a second mouse and it is doing the same so it is not the mouse driver
Update2: also tried a second keyboard …no luck

I have just tried SKUP 2017 (trial)
Same error…

My guess is something related to keyboard mapping, see if you can get some insight from these two links:

link 1
Link 2

If that would be the case the keyboard will be remapped for everything or everything will be affected
As far as I can tell only Sketchup is being affected

Possibly an installation issue, when you installed SU. Did you right click on the installation file and choose “run as administrator”? At any rate find the installation file , right click on the .exe, select run as administrator, then choose the repair option. See what that does