Bucket Tool not working, Push/Pull not working


#1

I’ve been using SU for about 3 months on a Dell XPS 400 with 3 Gig memory. No problems until recently and nothing was changed previous to the glitch. Researching the problem hasn’t produced a solution. On a newly created face, the push/pull tool acts like a move tool. If I draw a polygon on that face and try to push/pull again, nothing at all happens. Push/Pull works fine on an existing face of an earlier model. Push/Pull does not work on a previous model if I make a new face on it. The paint bucket only shows as the color picker. I can choose a color in the palette or the model, but can’t fill with color. Paint bucket doesn’t work on new or old geometry.
I eventually performed a full re-install of Windows with the same results. Rooting around the 'net, it seems that this problem has shown up across platforms and versions of SU.


#2

Try another keyboard, maybe the “Alt” key is broken?


#3

Are you trying to (re)paint raw geometry or a group/component, maybe a group/component with painted geometry inside the wrapper? Sharing an affected model will help get answers a bit faster.

Check Window > Preferences > Drawing. My Click Style is auto detect, and I cannot duplicate your P/P symptom. Play a little with those settings.


#4

That got me the other day, I had gone back to a model after a few days. I could not change textures or colors. After an hour of figuring it out, I clicked on the Outliner and forgotten that I had nested some pieces.


#5

Try updating, rolling back or reinstalling your graphic drivers.


#6

@iamdegman

You may go into the preferences and make sure your hotkeys didn’t get reassigned:

http://help.sketchup.com/en/article/114922

~~Drew


#7

Hey thanks everybody for the help,
This is a fresh install of windows and sketchup 'cause I finally got tired of the problem. A little extreme; but hey, go big or go home! Just wanted to prove to myself it wasn’t a windows problem. This thing happens even if all I do is draw a simple square and try to extrude or paint. Not cool at all. My control and alt keys are good, they work in SU and Inkscape. If you want to see what happens with Push/Pull you can go here…
https://www.youtube.com/watch?v=fBirWcPOWB0. I tried changing the click style, no joy. I had no hotkeys set up, reset anyway with same result. I do have a question tho. I tried disabling pre-pick for the push pull, is it then required to use the pointer to pick the face to extrude? I ask because when disabled, the push/pull tool still picks up the face on it’s own. Maybe it’s related.


#8

I forgot to mention I also disabled graphics acceleration. No change. Graphics card is on board-Radeon X300 128 MB HyperMemory. Force Z-buffer depth is Disabled, Triple Buffering is Disabled.


#9

Disable pre-pick removes the ability to pre select a face and then push/pull it without being on it. Normal hover over a face with the P/P tool will highlight the face and a click will select it.

Every other time I have seen your symptoms it has been a graphic card driver issue, and changing the drivers has fixed it. Reinstalling windows won’t necessarily change the drivers.


#10

I did a clean install from scratch, deleted the C:/ drive and started over. If it’s a driver problem then I would be up the creek without a paddle. No way to tell what driver or combination of drivers is the correct one. My computer has been stable for a very long time, it’s rock solid. SU was the only reason I did the fresh install. Why would SU work and then just glitch like that? Weird.


#11

Windows updates often mess with the drivers, did it start acting up after a Patch Tuesday?


#12

I have XP, far as I know MS isn’t sending any more patches. It started acting up about 2-3 weeks ago.


#13

I’m afraid I have no XP machines so can’t really offer anything else, could be anything, but as I said, only ever seen this as a stuck alt key or a graphic driver.


#14

I unplugged the keyboard just to make sure. Same thing. I don’t want to go messing with the graphics drivers. Not worth it for one program. If it’s the drivers, then SU is way too sensitive to a change in configuration. Thanks for the help.


#15

Well, despite my reservations, I installed the newest set of drivers I could find for my system. It didn’t work. I’m very confused about this whole thing. Deleting the C drive and a fresh Windows install from my original factory disks did not work. Installing the newest drivers available did not work. Yet, sketchup was working fine when I first installed it. Sketchup website states:
Lastly, you’ll want a card from a manufacturer who provides consistent and regular drivers for the card. Drivers are the set of instructions that the Operating System uses to talk to the graphics card. If those instructions don’t make sense because of bad drivers, you’ll probably see issues in SketchUp. Updating your drivers frequently is something that we recommend.
Why is that, when any random change can be the one that renders a perfectly working program into useless code? There is no way for a consumer to know if the “update”, is any good. I’m glad I hadn’t paid for the pro version, or was depending on it for a living.
There, I said my piece. I feel better now.


#16

OpenGL consists of about 300 function calls. If the driver developer decides to leave out critical function calls a program require, the program will not be able to do the task that required that missing function call.

ATI/AMD cards tend to cater to the video game crowd, which don’t require as many OpenGL function calls as SU. And lately there have been more reported issues with ATI/AMD cards. Historically, ATI/AMD tend to leave out more OpenGL function calls from their drivers than NVIDIA developers.

Disabling hardware acceleration causes all modeling work to be done by the CPU instead of sharing the duty between the CPU and GPU. If disabling hardware acceleration in SU then restarting SU doesn’t address the problem, odds are, your problem isn’t from a graphics driver deficiency.

The only way I can duplicate your P/P issue on a face is by pressing on ALT while trying to P/P.

Do you have any plugins installed? Some poorly written code can interfere with native tools.


#17

I had no idea OpenGL was that complicated. I’ve tried disabling hardware acceleration with no success. I’m using Sketchup for pretty simple stuff, just designing fishing lures. No plugins installed. I experimented with the keyboard unplugged and still had the same problem. Physically pressing the ALT key doesn’t result in anything useful. An Nvidia card might solve the issue; but no guarantee there, I would guess. Perhaps it may be best to go back to pencil and paper, but it is nice to get feel for the design in 3D.


#18

It doesn’t seem like a graphics driver issue as there was no change when hardware acceleration was disabled. Don’t throw money at this.

How are you choosing P/P - toolbar button, menu, keyboard shortcut? Do you get the same results with all three?

Did you check the keyboard shortcut setting? It’s found through Window > Preferences > Shortcuts.

Do you use the default MS driver for the keyboard/mouse or one from a hardware manufacturer, like Logitech? The mouse and keyboard have a control panel to adjust stuff. Are the settings as expected? Try updating the keyboard/mouse driver as this can become corrupted.

Whether your model is ‘simple’ or complicated, the underlying 3D calculations are the same. Besides, you’re only starting out with simple stuff. As your skills grow your later modeling projects will evolve.


#19

Hey Catamountain, I solved the problem-I just don’t know exactly what did it! I followed up on your mouse driver suggestion, and realized I hadn’t reloaded the Logitech mouse driver. I did that and set up my mouse, but no joy. So I went to Dell’s site to download the system detect utility, just for grins. Couldn’t use that because I needed the MS NETframework 3.5. That failed so I went back to MS and found they recommended to install windows installer 3.1 first. So, installed the installer, then NETframework, then Dell’s utility. Ran the utility, but I didn’t want to download the recommended stuff 'cause not that important. Started SU just to check and mouse was very slow. Went back to Logitec driver and unchecked use Logitech settings and checked use System settings. The mouse sped back up in SU and I could push/pull and paint bucket works!


#20

:smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: