Push-Pull Acting as "Move" tool


#1

Hey all,

I have been using sketch-up over the past 8 years, so I’m well versed in sketch and it’s interface. After downloading 2015 SketchupMake from my 2013 version, I immediately noticed the push-pull tool no longer functions properly. It acts as if I’m using the move too, instead of extruding a face. I have read a couple posts from others over the years who have had this problem to try to problem shoot the issue. I have downloaded old drivers, unchecked hardware acceleration, messed with “alt” and “cntrl” keys. I have rebooted the machine, done system restores to go back to the 2013 version. Nothing seems to fix the issue. If anyone has found a solution to this problem please let me know.

I’m running windows 7 professional - 64bit
graphics-AMD Radeon R9 200 Series
processor - intel® core ™ i5-3470 cpu @ 3.20 ghz


#2

Could it be that Push/Pull Pre-Pick is enabled?



#3

No sir. I have checked that as well. I’m starting wonder if the o.s. is
corrupted, but then again, I’m not having any other issues…


#4

If you mean that the selected face is extruded by PushPull [making sides etc], but the original ‘bottom face’ is not kept…
Then that is a function of the face.normal AND those of any surrounding faces too, versus the direction of the PushPull extrusion. The two back ones made from a single lone face keep the top and bottom faces when PushPulled, but those nearer the front - with more complex neighbors - do not… UNLESS you hold Ctrl while PushPulling, to force the original face to be kept, ignoring the affect of the neighboring faces…


#5

No, I mean that there is no extrusion at all. No sides created, no new
faces. The original face intended to be pushed/pulled is moved as if I was
using the move tool in sketchup or the translate tool in 3dsmax.


#6

What you describe may be a symptom of OpenGL deficiencies in your graphics hardware and/or its driver.
Try updating your graphics driver.
How can I update my computer’s graphics driver? — SketchUp help


#7

I guess I should have eloborated in the initial email to say I have checked
and updated to new graphics card drivers and reverted to older drivers
without any success.


#8

Does this happen with all your models or with only one? Is your model very far from the model origin or is it very large? Can you post an example?

Anssi


#9

I am having the exact same problem…Do you know of a solution? I’m using a brand new computer I ordered specifically for drawing software so I had it made with the best of any option I could, including graphics card.


#10

New computers usually arrive with out-of-date drivers.
Check your hardware manufacturers’ product support sites for updates.
Make sure the OS is up-to-date as well.


#11

I’ve updated all available drivers and also uninstalled/reinstalled 2015.
When the failed to work I reloaded 2014. same result.


#12

Do the driver test. In SU, go to Window > Preferences > OpenGL and disable hardware acceleration. Restart SU.


#13

I have still not found the answer. I have mostly given up looking for the
solution and instead downloaded blender… please let me know if you
stumble on the solution.


#14

This has just occurred with me as well. Sketchup2015, 15.2.685 64-bit

It happened, literally, in the middle of a drawing session a few minutes ago. I had been working for about an hour with no problems, drew a rectangle face as done hundreds of times before but this time the push/pull tool suddenly would not extrude faces. Only moved the selected as face as described in the previous posts.

Tried restarting Sketchup, tried in a new, empty modeling session, checked layer visual states…in all cases push/pull has ceased to function except as another move tool.

Will try removing and reinstalling Sketchup.


#15

I installed the latest version…15.3.331 and all is good (at least for now) with the push/pull tool.

So perhaps it was a problem that was corrected by the newer version or just by doing the re-install. Seems to imply that something got corrupted within Sketchup.


#16

With another user, this problem was isolated to a corrupted mouse/keyboard driver. If you rely on a 3rd-party mouse/keyboard driver instead of using your default OS driver, update it.

Coming from someone who has been there, yes, only SU performance can be affected by a corrupt mouse/keyboard driver.


#17

SU2017 with updated drivers on everything on Win10…

Just started to happen with me, as well, on a pretty simple model… do i need to somehow create a new face? Im not sure what to do…

I might import it into blender, just to fix that and then bring the model back into SU.