I can't pushpull

Hi, I am new to Sketch up. The push pull tool doesn’t work for me. When I hover over the area I want to extend nothing happens. I’ve tried doing this on the web free version and sketch up make version (free trial). Are there operating system requirements to use this software?

Pushpull works by extending a single selected face normal to the face. What you show as your OS and graphics card should have no problem handling SU.

Can you describe the steps you are taking that ‘don’t work’?

And/or upload the model in which you are trying to use pushpull. Drag the .skp file from your file manager into your next post.

Most likely you have either a group/component that isn’t open for editing or you have a surface made of multiple faces. Can you share the file?

Thanks for your feedback. I can’t seem to drag the skip file over, sorry. I have attached a picture. I have:

  1. created the dimensions for the back of my campervan
  2. I click on the push/pull icon, drag it over to the shape area but the shape doesn’t grey out (like it says it should in the tutorial)
  3. When I click and try to extend the shape nothing happens

In your screen shot there’s no face for Push/Pull to act on. Most likely the edges are not on the same plane. Orbit around to look at it from the edge. That may make it clear. At least as you are starting out, you may find it easier to start by drawing a large rectangle and doing your drawing on that.

1 Like

There’s no face within those edges.
If there were you could pushpull it.

It might be that the outline is not coplanar.
If so it will never be able to support one face.
If you redraw a simple vertical rectangle larger than you need, then you can draw over that to give the exact outline you want.
If you’ve let the new edges/arc[?] snap onto that rectangle, then the face that your delineated should then be pushpull-able.
Delete the unwanted extra edges [and their face[s]].

1 Like

Thank you very much. I’ve created a basic rectangle and now the push pull has worked. I had previously downloaded the the 2017 make version and followed a step by youtube tutorial to create the exact height/width dimensions of my van but then I had issues with push pull. I will persist. Thanks again

Spend some time learning the basics at The learning Center. This is put together by the Sketchup team.

Thank you