Push Pull does not work properly

Thanks people for reading this. I have been sketchup user since a while maybe 7 years and I noticed that the push-pull tool from one day to another has this issue. When you select the element you want to push-pull, instead of make the extrusion, it moves the whole element. This tool only function correctly when I use the measure tab bellow, but is very difficult to make windows and doors holes, if you know what I mean…
Many thanks for the support.

Something like this has been reported before…

Can you try and update your Graphics Card Driver to the latest version, and ensure its settings allow the 3d application to choose its own GC settings…

Restart SketchUp and see if that helps…

Report back…

1 Like

Thanks TIG,
How can I update the Graphics Card???

How can I update my computer’s graphics driver? — SketchUp Help


Thanks pal, I already update my graphic´s card, it is a NIVADA GEFORCE GTX 880M, and nothing changed with this sketchup´s pull-push error… I also installed again and nothing change.

Many thanks.


If you check your system what is the Nvidia Geforce GTX 880M version ?
Is it the one offered on their web-site ?

Assuming it is the current version, have you checked its Control Panel to see that the 3d app chooses its settings ?
Have you also tried opening Preferences > OpenGL and using various combinations of the settings ?
Some of these might resolve the issue…
Switching off ‘Hardware Acceleration’ should disable the GC and if that doesn’t fix the issue that something is adrift elsewhere, but it’s unlikely to be a SketchUp alone issue…

I did it and nothing… Everything remain the same…

Any other idea?


You did not answer the question about the driver version.

Did you try ALL of the possible combinations of the OpenGL settings ?
Did you try switching off OpenGL Hardware Acceleration ?

You might need to restart SketchUp to see the effects.

Are you sure the Nvidia Control Panel is set to alow the 3d apps [as is SketchUp] to chose their own settings ?

Thank you very, very much TIG, I have tried several settings configurations, enable, disable, etc, etc. The thing is that at the end I don´t know which one of them was the good one, If you know what I mean. But certainly it has to do with this OpenGL configure.
My sketchup now is working just fine.
Thanks again man.