Push/pull doorway


#1

hi everyone
I am trying to push this doorway threw 100mm (the thickness of wall) but when i type 100 on my OSK it adds the 100mm to the all ready partially pushed distance so it ends up ~124 and doesn’t make a doorway?

any advice would be great

NoHands


#2

That is odd, it sounds like you may be accidentally hitting something else before you type. It’s hard to know without seeing.
I tried it with my OSK and I get these version.

By the way, if your model is less than 3mb you can attach it here so we can check what is going on more easily. Bigger you can upload to warehouse, dropbox etc.


#3

bubble3 wall offsets.skp (832.0 KB)

hrere is the file that was exactly what i was doing but it kept making a extrusion the other way instead of cutting out the doorway I ust be doing something wrong tho

how did you make that little gif i could show you whats happening with me
Cheers BOX


#4

Sorry Shane, somehow I missed this and I’m only using a phone just now so I can’t check your model.
For the little animations I use one of the various screen capture programs that save to gif.
I mostly use gifcam but it has some issues. Others that spring to mind are licecap and screenpresso.
I’m traveling for a few days without real acces, so hopefully someone else can have a look and give you some advice. From your screenshot I would check that you have faces orientated correctly and that there is a second face on the wall you are trying to cut the door through.


#5

I found a couple of issues in your model:

  • The back face of the wall is missing where you are push-pulling the doorway. I don’t know if it started out like that or was a result of some other manipulation along the way.

  • The existing extrusion stops just a tiny bit shy of where the back face of the wall should be. This interferes with restoring the back face.

I deleted your existing extrusion, carefully including that not-quite-aligned edge. Then regenerated the back face of the wall by drawing the missing edge at the bottom. Then I push-pulled the door through, using an inference from the top back edge of the wall to get the depth, and it worked fine.

Edit: here’s an animation of the fix:


#6

yer its really a rookie mistake I’m gonna start the house again I got some help from a advanced user so my next model should come out a lot cleaner
thx heaps

No Hands


#7

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.