Purging Embarrassingly Large File

So, I’ve been working on this model for a commercial renovation for about a year now, and it’s slowly grown to a shameful 1GB due to a huge number of client changes (they like to see the space staged, so I’ve used a lot of warehouse components). I didn’t really notice, because this PC is pretty beefy and even realtime in Enscape didn’t slow it down too much.

However, the time has come to hand it off to another team, who are struggling to open it. I’ve tried deleting all extraneous geometry I can find, but that only cut down a couple hundred megabytes. I’ve purged unused materials, but that only took care of a handful – it seems the majority are applied to components that don’t exist in the model space. I’m now trying to purge components, but doing that in one go keeps crashing SKP.

Is there a way to list/manually purge smaller groups of unused components? The geometry I create is generally fairly low-poly, and my personal textures are pretty limited, so I have to assume there’s about 800mb of extraneous components.

You could delete them one at a time by right clicking on their thumbnails in the Components window and choosing Delete. Cancel it if it warns you that all instances in the model will be deleted.

You might see if turning off Profiles and Edges in the style helps to lightening the load. If you want to share the file I’ll take a look at it and see if I have beeter luck. Upload it to DropBox or WE Transfer and share the link.

Aha, I must have missed the delete option, and they key wasn’t working. Sounds like I’ve got a relaxing Friday afternoon doing that a couple thousand times :'^)

So, does this mean Sketchup caches all components you’ve ever imported as part of the file?

pretty much, if you add the component, then default instance is in there. and many items in the warehouse are excessively heavy. beside breaking up the model into multiple types (structure, MEP, finishes, etc etc) as a means of keeping the master model easier to maintain, loading components into a blank model and checking it before copying it into your project files is always a good idea - you can check it for scale, size, materials etc and adjust as needed before copying into your project and thus avoiding a lot of extraneous stuff as well as things out of scale etc.

1 Like

Seems like a feature it would be nice to have the chance to turn off - it looks like every single block from every single AutoCAD import has also cached and has to be manually deleted.

Personally, I’d much prefer to have to re-download the occasional prop than have a file slowly bloat unless regularly purged. Opening in a new file is nice when you’re working at a leisurely pace, but not really tenable with people watching over your shoulder.

1 Like

Another possibility would be to select all that is shown in model space, so that any unused components shall remain unselected.

Then you copy the selection and paste it in a freely opened copy of SU.

Of course you will not get all the scenes of the original.

Dave’s method is probably the best.

1 Like

Open it to a scene which has everything you need.

Open a new drawing file.

Select all in original. Copy…

Paste in place in new file.

cross fingers

If the file is as large as you say, go make coffee.

Come back to see everything pasted in the new model.

Save the new file.

Go to original.

File Save As…

Delete everything.

Open Outliner.

Delete all objects that might be in the Outliner. Turn on hidden geometry and hidden objects.

If you have scenes with sections be sure not to delete the Sections. Double check that you have deleted everything.

Open components library. Purge unused.
Do the same for materials.


Close the file. Find the file with your file browser and see what size it is. Hopefully it is now much smaller.

Open the file.

Go to the new file. Select All… Copy…

Switch to old file - be sure to close the outliner.

Paste in place.

cross fingers

Enjoy some coffee.

If it works everything you wanted will come back to where it was. And your scenes and layers will still work. I would then purge the model of everything you don’t need again, just to be sure.

If the file is too big do this in steps. I often have to setup models in a separate file for render - so I turn all my tags off, then one by one turn them on and copy / paste in place into a new file, one tag at a time.

1 Like

Purging the file itself in the model statistics screen or the components/materials/scenes settings will remove everything from the project that isn’t physically used in the scene. That will lighten the load significantly from the sound of it.

Once you’ve done that there are a couple of extensions that will help you identify the more painful models that could do with being swapped out.
Goldilocks and CG impact report

There are also plugins to physically hide the edges on a component itself - that way you don’t have to keep edges/profiles turned off for when you need to actually edit something

1 Like

I can’t believe I didn’t think of this - thank you.

Marking this as the best solution - in my case, scenes can be re-set-up much more quickly than trying to delete all of those components. Even after an hour or two of manually paring them out, it still crashed trying to purge the remaining unused.

Copied and pasted the model into a new file and immediately brought it down from 1GB to 200MB. I was worried the model would be too large to copy & paste without crashing, but it was totally fine!

1 Like

Large files suffer performance slowdowns due to the total number of groups and components, especially if there are transformations (scaling, strretching) applied and lots of nested objects.


You have a garden with 40 plants, and each plant component contains 200 sub-components (for leaves, stems, flowers, etc).
To add variety you have scaled up some plants, rotated and flipped them, and applied some variation in default material.

Try editing each plant and exploding all the small components within it.
You’ll probably find that Sketchup runs much faster .

Goldilocks doesn’t seem to work for me. It does identify some rather large components, but I can not find them.

Eventually, I found the materials - which was difficult without a “search” option in the window.

But I can not find the components. I tried the Components window by copying the component name into it, but it doesn’t show it…And I also tried to use the Outliner…

It is a rather large file, which I am trying to reduce because the Layout is very slow - even when I am only drawing over the viewport…

I would also welcome any suggestions on how to make Layout work faster while drawing. It is painfully slow - copying lines, drawing…I use "low " resolution in Document Setup/Rendering at the moment. Sure, having a heavy style probably doesn’t help, but it is part of the look. Do you use different styles to edit and then change it before printing? Seems quite a fuss.

I wish there would be an AI feature that could temporarily delete everything out of the viewport which is out of frame…

Any tips?

Share the .skp file so we can see if we can help.

The style you show in your screenshot won’t help with speed in LO. If you want to use it in viewports in LO, add it to those viewports in LO after you’ve set the viewports up and added any annotations or whatever. No need to add the style in the SketchUp model.

Thank you. Here is the link.

I know that the vegetation is quite big, but I can not find the first few components listed on the Goldilocks extension.

I thought that by clicking on the link(in the Goldilocks window), it would select the given component and with Alt+T I could zoom straight to it.

I made this model quite a few years ago, so it is not as organized and clean as I would like it. I am trying to clean it up now, mainly to make Layout work faster.

that’s the donut blender file :stuck_out_tongue: Wrong one.

I am so sorry. I just changed the link…

Goldilocks does select it if you click on the name - but if you’ve hidden the object via a tag then it can’t select it, so make everything visible first.

Removing the plants from the garden and the 2 people inside takes 3million edges from the model - this is what Layout will be struggling with.

Thank you