Pupils unable to login - Error Message - An error has occurred

Pupils have been accessing sketchup for schools app on chrome books for a number of years absolutely fine. Today some pupils are now seeing “An error has occurred” That’s all we know.
When they select their user name to sign in with their google accounts.
Checked the Data access in the google admin console and the status: Granted.
Cleared their browsing data but this has not resolved the issue.
Any thing else I need to check?

Glad we aren’t the only ones! This issue appears to have popped up out of the blue. Any suggestions would be great!

Just wondering (haven’t tested it yet) its to do with google domain changes ie the new App access control in the admin console.
Off topic just had a whole class unable to access GeoGebra until I changed it to Trusted. I can see Sketchup in the list and it shows “Limited”.
When i get a minute will do some testing. And report back

Ok I have now changed “Limited” to “Trusted” and this has made no difference.

We also have a school getting this error. I’ve been through the whole of the forum post Signin Error - #3 by vineyb which seemed to relate errors we were getting a couple of weeks before this new error. Pop ups seem to be allowed - not seeing them blocked - and then any of the other fixes mentioned further down in the post don’t appear to be available - i.e. trying to follow the route to get to the settings mentioned don’t work. I did manage to finally find a setting about the Classroom API / Data Access but it was already on. The app access control for Sketchup is Trusted (Google Workspace MarketPlace). I’ll try logging a call with Sketchup Technical support but if anyone has any tips about resolving this error then it would be great to hear what you’ve done.

Ok just doing some more testing I have created a test OU which sketchup is applied to I then turn it off and then try sketchup again and now get the "Are you in the Right Place? I then turn the App On and the test account I am using sketchup seems to work.

I will do some more testing but so far in the admin console App distribution turning it off then on again seems to work!! Of course it does :slight_smile:

Doesn’t work work us :frowning: Turned off and on and still not working.

Any more ideas anyone?

Thanks for your suggestion cccitsupport. How exactly do you turn the Sketchup App off and then back on again. Our Sketchup app is pushed out from the Google Workspace admin console via Devices > Chrome > Apps & Extensions > Users & Browsers. The Sketchup for Schools app is associated with the Users OU with an installation policy of Forced Install + pin to ChromeOS taskbar. I tried changing this to an installation policy of Block on a test OU underneath users and then changing back to forced install, but it had no effect. Is that the route you were following to turn the app On and Off, or is there another way?


We created a test OU and placed a test pupil account that experiences the error in the OU and then we goto:

Apps > Marketplace apps > Settings for SketchUp for Schools > Service status

On this Page is where you can turn it on / off for specific OU.

Before we made any changes, we made sure the account still didn’t work.

We then changed the service status to off.

Using the test account I tried sketchup again - We then got the message "Are you in the Right Place?

We logout the test account, change the service status to on login and try sketchup again this time round it asks for access to google drive etc… (like the permissions have reset) and it starts working.

However I did place another test account that experiences the error in the same OU, didn’t login to the account whilst switching the service on and off and for this account sketchup has remained not working.

Will keep looking and testing

Thank you all for reaching out, and please know that this issue is being looked into by the SketchUp for Schools team. Would any of you be able to provide a screenshot of the error that you’re receiving when attempting to log in? It may assist us in troubleshooting the issue.

Thanks for getting into contact I have upload a screenshot which does not give much away.


I ran across this thread searching for others with the same issue as our application is currently having. We are currently affected by this issue and it started around the same time that this thread was created.

I would love getting in touch with your team to discuss what we’ve found regarding this issue and what you potentially might have found.

@cccitsupport and @ITDuckling and @REDodson and @john26
What devices are you seeing this issue on?
What browser do you use to open edu.sketchup.com? Are you using standalone browsers?

We are using mainly Chromebooks, But I have tried it on a Windows 10 PC running chrome browser Version 114.0.5735.199 and logging into the browser with my google domain account and then went to SketchUp and signed in and get the same error message:

An error has occurred. That’s all we know.

In the school they are using Chromebooks. The majority are running either 114.0.5735.143 or 113.0.5672.134 of the ChromeOS. I am recreating the error on my Windows 10 PC in a Chrome Browser ver. 114.0.5735.199 (Official Build) (64-bit). I’m logging in with a test student account from the Google Workspace of the school reporting the issue. I’m then opening Sketchup from the Google Apps waffle for that user. When I do that I then get the pop-up prompting me to login with the account I’m signed into Crome with. I select that account, I get a “Sign in with Google” pop-up, listing the account I am signed in with again. I select that and then I get the “An error has occurred. That’s all we know message”, the same as posted above by cccitsupport

We’ve been having the same issue, we’ve only seen it on windows 10 22H2 machines.

On the effected machines we’ve seen the error using Chrome 114.0.5735.199 and Edge 114.0.1823.67. But for us it seems to be dependant on who logs in, not the machine itself.

We also need this error resolved ASAP. We use Google Workspace for Education Plus and our domain is cha.org and needs whitelisted please.

Excited to use sketchup for some upcoming projects for next year, and having the same problem! If anyone has any solutions from the tech/admin side, I can relay. Otherwise, hopefully it’s a sketchup issue which gets solved soon. Thank you!

We`re getting the same issue here, has anyone found a solution to this yet?

I have a ticket open with Trimble and Sketchup regarding this issue. They said they would post an update on this thread.

Please request whitelisting here