Project suddenly deleted

I’ve been working on a project in SketchUp free for months. I was working on it in Safari 14 today, when:

  1. I switched to another tab
  2. I started tethering from my phone, because my home internet was slow
  3. I returned to the SketchUp tab
  4. I was greeted by an “Accept our terms and conditions” modal
  5. I clicked OK
  6. My project was deleted

My last backup was months ago, so I’m distraught. Now I’m curious:

  1. What happened?
  2. Has this happened to anyone else?
  3. Is there any way to recover it?

Try clearing your caches and then sign into Trimble Connect with the same email address as previously used. Do you see the file?

After the deletion, I reopened SketchUp in Firefox and the project was still missing.

How many models did you have, and can you give the name of any of them?

I will take an educated guess, and make suggestions, in case you don’t see my message for a while.

If you have one model, make sure you are signed in with your Gmail address, and that the region in Trimble Connect is set to North America, and not Europe or Asia.

Appreciate the help

Only had one model (although I imported several into it): Promaster 1.skp

I was signed in with Gmail. When trying to edit my profile, it asked for a password (which I didn’t have, since I signed in with Gmail). After (re)setting the password, I was able to set the region, language, and timezone. My Billing Information was still in Spanish, so I signed out and signed back in; then it was in English. I then opened SketchUp Web, but the model was still missing.

My backup from August 8 is 21.8MB and I’ve added quite a bit since then, so the file may have grown pretty large.

Oh wow. I just found it. It’s accessible via Trimble Connect, but not app.sketchup.com

So signing in via Trimble Connect worked as I suggested?

I do see the model, it is still in your account, in the North America region. It’s possible that whatever led to I being in Spanish also connected you to the Europe region.

I will send a direct message to you with a link to the page where the model is, and you only have to get the sign in part correct.

It did! Apologies for the misunderstanding. When I clicked “Sign” In in the upper right on sketchup.com, I’d assumed that was Trimble Connect as it redirects to identity.trimble.com then “Trimble Account Management”.

Yes, unfortunately Trimble Connect and the web app don’t share sign ins. If you signed in to the web app in the same way that worked for Trimble Connect, the model should have shown up in the Trimble Connect section of the web app.

Something else to know, the Home part of the web app is only showing recent files. That can get emptied for various reasons, that do not mean the models are gone.

This topic was automatically closed after 91 days. New replies are no longer allowed.