Missing project in Sketchup Web

Hi everyone,

My daughter used Sketchup Web (Free version) to model an object for a high school project. We downloaded the STL file and sent it to her teacher, but unfortunately he wanted another kind of file. When logging back to her account, the project is missing. I am 100% sure we never removed the project. How come can it be missing. Is there a way to restore it?
Needless say she is extremely worried about that…

Surprisingly, the project does not even show up in Trimble Connect Sketchup folder. Not even in “Activity”. And again I am 100% sure she modeled her object using the only account she has (she has only 1 email address).
Is there any way SketchUp Web may have erased the project without us knowing about it?

The model is not likely to have been deleted. If you don’t see it that pretty well always means that you have signed in with a different method.

For example, if you signed in with your Apple ID, but chose to hide your email address, we know you under a different address, one that conceals your true email address. If you later on sign in with the real Apple ID email address, using the sign in with Trimble approach, that will seem like a different account.

If there is a chance you did at one point sign in with Apple, try doing that again, and you should be signed in to the original account.

What file format does the teacher want?

Hi Colin
Thank you for answering so fast.
I checked again, but she only uses her GMail address. She has an iCloud address but she does not use it (and she cannot use it for SSO purposes as she is under 15).
Another hint: she had 2 projects under her account

  • one bogus / test project (still available)
  • the project she was working on.

She clearly remembers that the two projects were visible side-by-side. That would not be the case if she was working with 2 separate accounts, right?

Just to make sure: yesterday I exported, deleted and restored her test project and it worked fine. I can also see that I did these operations under the “activity” section of her Trimble account. But nothing about her project for high school. Not even a mention about the creation of a new project. Strange isn’t it?

Regarding your last question: the teacher wanted the .skp file, while we only exported the STL (which is still something).

As a workaround, you can use insert to import the stl into a new model, then use Download to get the .skp to send to the teacher.

try changing the server location in Trimble Connect:

go to connect.trimble.com and sign in

Then, change the server location.

is the ‘bogus’ project called SketchUp?

Hi MikeWayzovski,
Thanks for answering.
Yep I did that too. No project in NAM nor Asia, only one in Europe (the test one).

So try logging in with the Google sign up

I did that too, and it connects to the very same account, with same project.

Hi Box,

Nice workaround. I tried it and it worked. Of course, we lost the colors and textures as I guess the STL only contains data about the shapes… but that’s 95% of the work we restored.

Thanks a lot!

I still wonder where the original project went, and learned a lesson: make a local backup everytime we change something in the project. :slight_smile:

I have lost all my projects in SketchUp. I know that they are saved because they were possible to open a couple of weeks ago. I have tried to find them in Trimble - all parts of the world is tested but they are not there. Could they have disappeared during some updating of the Sketchup web application? I would really like to have them back because they are the foundation for a house we are going to build.

You might have been logged in with another Trimble ID.
When you last signed in, did you use the Apple sign in button?
If so, try to use the yellow Trimble Button instead or viceversa.
There is a chance when signing in through Apple, an alias email is created on the fly.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.