Programable Mouse Problems – Mac

mac

#1

Mouse: Logitech M720 Wireless

Mouse Application: Logitech Options (current version for Mac)

iMac Specs:
PNG

Task:
The user is trying to map the Arrow Keys to the mouse buttons.

Problem:

The Enter Keystroke field fails to accept input when pressing an Arrow key.
But the Enter Keystroke field readily accepts input when pressing a Letter key.


#2

It must be a Mac thing. With Windoze the field accepts the arrow key.


#3

Perhaps @TheOnlyAaron knows how to make an old Mac learn new tricks?


#4

I can take a look. Honestly, I have never tried to map an arrow key to my Logitech mouse (they are mapped to shortcut keys on my Spacemouse).

Just because I have not done it before does not mean it cannot be done, though!


#5

I only have the most recent release on High Sierra, but I have no problem mapping an arrow key to a button in Logi.

Keyboard thing, maybe?


#6

I was finally able to assign keystrokes to buttons on my M510 but it took a lot of tries to get it to stick. I attempted a number of different keystrokes before getting single keys to stick. It seems like I had to first type something like SHIFT+M and then replace it with just M to get the M to stick. If that’s the way it is supposed to work, it’s not very intuitive.


#7

I think we have pretty much concluded from another similar thread that Logitech’s interface doesn’t work properly with a Mac. I have an MX Ergo and I cannot map keyboard shortcuts to the buttons. @DaveR seems to have found a way of doing it with his mouse but it clearly isn’t reliable. Logitech have stopped responding to my complaints about this functional failure which I guess is because they don’t know how to solve it.

You can type a key into the “Enter keystroke” box but as soon as you navigate away, it disappears. I don’t actually know what it means by a “valid key combination” as you don’t necessarily have a combination for a shortcut. But using a modifier key doesn’t work for me either. I cannot use this feature at present.


#8

Are you guys sure that Universal Access or your machine’s keyboard shortcuts aren’t interfering? To confirm, go back to defaults in System Preferences->Keyboard->Shortcuts, and try toggling Ctrl-Fct-F7 (like the SketchUp ‘cursor starts elsewhere, so when I hit space-bar I get Geo-location instead of Select Tool’ issue) to see if anything changes.


#9

Mine shows “Text Boxes and Lists Only” as being selected.


#10

And mine is always ‘All Controls’ so that often I can hit Enter for one choice, space bar for the other, because on this first-world-problem planet, I simply don’t have the time to hit tab, because one tab leads to another tab and pretty soon I’m wearing out my tab key.


#11

Mine shows “Text Boxes and Lists Only” as well, and i have no problem with mapping keys to my mouse.


#12

Mine is like @DaveR’s and @TheOnlyAaron’s. I have looked through all the options and I don’t have M in use already, so I cannot see how there would be a conflict as @Barry suggests . Anyway, if there were, you would expect the Logi interface to accept the key setting and just not respond (or do something weird), wouldn’t you? Or if it was clever enough to “foresee” the conflict, there would be a warning of some kind.

Logi have been back in touch but it’s not encouraging:


#13

STOP PRESS! I think I may have solved it - sort of.

I was trying to do what worked for @DaveR and suddenly a dialog box popped up asking to allow Logitech to control things. I am pretty sure this came up during installation and I said yes. Anyway, the relevant box was unticked. After I ticked it, things began to work.

It says enter a “valid key combination”. For me that seems to mean there has to be a modifier key. I can’t get it to work with a single key press. Even trying to delete your selection is difficult because it then accepts that as the input! The workaround for me will be to change my SU shortcut to Ctrl-M because it doesn’t matter if I use the mouse button instead.


#14

Don’t hit the Delete key. If you entered Ctrl+M and want it to be M, select the text and overtype it with M. That’s what I found I had to do.


#15

Tried that (several times). Couldn’t make it stick. Even thought of trying ASCII code but that didn’t work either!


#16

BTW, anyone understand why Logitech needs to have access? I am not that keen on allowing foreign firms access of this kind unless there is very good reason.


#17

I’ve complained to them about this for years. The old Logitech software didn’t require admin access to accessibility to customize buttons, but the newer software does. I was forced to work with my IT department for a long time in order to finally grant Logitech Options access to this. After I did I finally got full ability to customize my MX Master buttons.

My new issue is that Logitech Options doesn’t seem to recognize the Fn key on the newest MacBook Pro models. This means I can’t set a page up/down anymore. Frustrating for sure.


#18

Logitech appears to be a Swiss company so at least not Chinese, Russian, or any of their satellites.


#19

I found this statement from a 2013 article.

“We make everything in China,” Logitech CEO Bracken Darrell said on Bloomberg TV. “About half of what we sell, we make, and half of what we sell, we source from somebody else. It’s an interesting strategy. It’s really worked for us over time.”


#20

Oh boy! Should we be worried? First we get stories about China implanting little chips in hardware, now this!

I might review whether the added functionality of the mouse is worth the possibility of letting China in through a back door.

And I’m not paranoid, it’s just that everyone is out to get me.