Keyboard shortcuts not registering upon first press - sketchup pro 2023

Sketchup pro 2023, I’ve noticed something that Eric had on the live stream last week, Eric thought he kept missing the key but having seen it happen to me i think he wasnt missing the key :slight_smile:

It seems when i’m swapping between tools with the shortcuts, sometimes it doesnt register the first time the shortcut is pressed and requires a 2nd press to activate.

I dont know if its a timing thing but i’ve mostly seen it swapping back into line tool and orbit, i notice the icon seems to remain on the previous tool until its double pressed also, so i guess it’s not catching the first entry for some reason

cheers

Check if the maintenance update released yesterday fixes this problem.

1 Like

updated, the problem is still there and now the Del key doesnt work anymore in the 3d window, in the prefs it is recognised, but only not working in the 3d viewport :\

An update.

I added another keyboard shortcut to the delete function and it doesnt work either, so seemingly the delete function itself is broken

I went back into the prefs and the assigned key (insert) was no longer listed, when i attempted to readd it sketchup popped an error saying it was unassignable, but mapping it to somehtink on the normal keyboard means the delete function is working, but the delete shortcut in the numpad is not.

most odd, it was working last night after i updated to 2023

as closure on the keypad not working, Sketchup support provided me a link to the initial 2023 release and its all good now, keypad functioning as expected

Eric, and the others who do live modeling, don’t use the latest version we have internally, they use the most recent release version. Which means it would be possible for them to see problems other people are seeing.

But, they all use Macs, and the keyboard issues only happened on Windows. I did have the live stream on while I was still working, but didn’t notice him having problems. I will check to see if he remembers what had not worked.

I should also make sure they update before tomorrow, though it’s not urgent, the improvements on Mac were mainly in LayOut.

it was when eric was trying to move/duplicate, it wasnt registering the option key being pressed, after i posted i continued to use it and noticed that it was also the control key which showed up the most - especially when using the scale and toggling on center, it would toggle on for a fraction of a second then off again, requiring another press.

thanks for the reply!

Move tool doesn’t have the dual behavior that some tools have. Eric may be old school enough to have tried Option-drag to make copy. He would need to have tapped Option, then done the drag.

select object, click m, click ctrl to create the copy , the ctrl fails to register and you end up moving the original instead.

the ctrl is the option i was refering to as the option use of the move tool, a misunderstanding in terminolgy i think.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.