Problems with scale in Layout

Hello, I have just transferred my SketchUp drawing to Layout and when I try to add a scale it does not work. When I go to add the scale something shows up that says click to start drawing in the particular scale and then I click and it just reverts back to having no scale and the scale sidebar goes back to giving the option to add a scale.

I used to know how to do this with Sketchup 2018 but I do remember having some issues at first but can’t remember how I solved it… Something to do with selecting the drawing??? Your help is much appreciated.

How about sharing the LayOut file so we can see exactly what you’ve got?

It looks like you haven’t set the camera to Parallel Projection in SketchUp.

Here is the layout and sketch up files. Thanks. fileDoor Elevation.layout (155.7 KB)
Front Elevation of Door.skp (138.8 KB)

My guess was correct. You have the camera set to Perspective, not Parallel Projection, so scale isn’t available.

I set the camera to Parallel Projection and created a scene in SketchUp to have something to link the viewport to. Saved and update the reference in LayOut and presto! Scale is available.

By the way, there are a lot of faces in your model that are oriented incorrectly and you you need to create scenes in your model for the viewports in LayOut and then avoid modifying those scenes once you get into LayOut.

Well I am glad you solved it however I am not sure what you mean by creating a scene in sketch up? I switched the camera to parallel projection saved the file and tried sending it to Layout again but had the same problem with adding a scale.

Also I am not sure what you mean by my faces are oriented incorrectly? I measured and drew my lines using the tape measure and guides. Then I was planning to use the dimension tool in Layout to add dimensions where I need to.
Thanks very much.

A scene sets a camera position and basically a fixed view of the model. You create the scene after setting up the desired view in the Scenes panel in the tray.

Because you still have a modified Last saved SketchUp view instead of a scene. At the very least, select Last Save SketchUp view from the drop down list.

The problem with use Last save Sketchup view as your “scene” in LayOut is if you go back to SketchUp to make changes to your model and wind up changing the camera position. When you return to LayOut and update the reference, your viewport will be screwed up as will any dimensions or labels that you attach to the model in LO.

It’s not the measuring and drawing the lines. The blue faces are reversed faces in your model. You should only see white faces.

Actually if you’re only going to have a 2D drawing of your door, you could just do that directly in LayOut using Scaled Drawing.

Okay so you are suggesting that for my purposes I should just use Layout until I may want to make something 3D?

I do find that SketchUp is easier to work in than Layout and this is what I did in the past (last year when using SU 2018) and I never had a problem with the scale when transferring to layout and I also did not do anything with scenes or the parallel camera etc. I was just working with 2D sketching.

Is there anyway you could send me back the Sketchup file with the adjustments you made to have it become scaled in Layout? Unfortunately it is still not working for me.

Thanks a lot

I’m suggesting that since you aren’t creating a 3D model, there’s little point in using SketchUp. With the Scaled Drawing feature in LayOut, something like your door would be as easy to draw in LayOut as it would be in Sketchup.

Your workflow leaves you open to all sorts of issues and potential problems as you move forward with your project but it sounds to me as if you aren’t concerned about those.

That would indicate to me that you aren’t doing what I told you to do. If you did what I told you, it would work.

Here’s the file. Compare it to yours and see what yours is missing.
Door Elevation.layout (290.5 KB)

Thank you. For my future drawings do you think it would it be better if I just used SketchUP until I am done everything and then transfer it to Layout just for labeling and dimensions? This is what I did in the past with SU 2018 and it worked for 2D drawings. I found that I didn’t like drawing in layout and that the tools were harder to use in Layout.

Are you going to end up making 3D models at some point? If not, I guess I would just learn to use the tools in LayOut. If you are going to make 3D models, then start in SketchUp. I’d make a 3D model before going to LayOut, then, and create a scene showing the model in 2D for dimensions.

I would like to eventually do 3D models. Of course I have a lot to learn though as you have opened up some issues for me to address. Thanks again.

Just wanted to add that the solution I was looking for which I figured out after too long was just to select my work in Layout and then right click on it and it provided an option to scale it. ( I had transferred my drawing from SketchUp to Layout).

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.