Problems with measurement toolbox (again?)


#1

I am sorry to bring the problem again, I have read several threads about the subject, but after a few hours, reading the posts and trying, I am still incapable of the most elementar operation -> drawing a straight line (segment) between two points with known coordinates. (I started with SketchUp just a few hours ago).

I have commuted on and off several time the “measurements”, with view->toolbars->measurements.

I have used “,” and “;” to separate the coordinates, and I have used - and also have not used - [ ].

My “locale” is always EN-US, except if a program changes it. That is the lingua franca for the people I work with and/or are significative. I have even tried the “Ruby Console” thing, to change that. I write in 3 languages (sometimes 4) and that has not been a problem. Win7.

I started with Draw->Lines->Line

As a result I got the pencil icon I can move it using the mouse. It works for freehand drawing,

However I do no manage to type in the coordinates, any coordinates. I have NOT clicked in the “measurement toolbox” (How could I ? I do not find it! ) and typing anything in the keyboard, seems to me, does not cause any effect or change anything I could see.

I am just staring with SketchUp, I have some experience with AutoCAD and microstation, not as a intensive user but like a teacher, a developer and a project tech manager.

Thanks in advance,


#2

It seems to me this is the only mention in your entire post that you can’t see the Measurements toolbar on screen, which may well be the crux of your problem. It could be that the Measurement toolbar is simply pushed off screen. Have you tried zooming (maximizing) the SU application window?

-Gully


#3

Is it possible that you haven’t hit Enter after typing.
Generally it’s Click release to start an action, move mouse in rough direction, type input and hit Enter to complete the action.


#4

There should be a display box in the lower bar that displays the length of a line. If you click a starting point and move the cursor in the direction you want the line to go, you can type in a value followed by the “Enter” (or “Return”) key to set the length of the line to any value. In the animated GIF below, note the values displayed versus the typed in values and the behavior of the line being drawn:


#5

thanks jimhami42 but I do not want to click at the “click at the starting point”. I want to “introduce (type) the starting point coordinates”.

(or probably I am missing something…)


#6

You can enter the end point for the line either as absolute or relative coordinates but you can’t enter the starting point. You could place a guide point at the desired coordinates and start the line from there.


#7

thank Gully_Foyle

I have now maximized (and minimized a few times) the the windows. Found no difference.

I have a small area of the screen where we can read “length:”. Is that the measurement tool box ? (from jimhami42 …) . And yes I can easy type in the length, but not the coordinates, and not the coordinates of the inicial point.

(or I am missing something…)


#8

Thanks DaveR, and thank you all.

I am realizing now (please correct if am wrong) that we can not type directly the coordinates of the first point of a line (at least without introducing a extra point (guide) point).

I had always assumed that the obvious way to draw a line segment was to specify its coordinates ( inicial + final ).

I am also realizing that the “mesaurement toolbox” I could find was there all the time. I just did not recognize it, in part because it was not “responding” - it respond only after I click the first point (with the mouse, what I was not doing).


#9

Yes, the measurements box only becomes active when the selected tool is ready for an input. that will vary from tool to tool.