Problems with global axis randomly changing

Sketchup Pro 21 on Windows
Hi I am a long time user I keep my files a reasonable size and have always had a stable installation.
I am using the latest release. I have been drawing small room sets and the last 2 days it seems to be glitchy. The global axis changes randomly so my model is suddenly 6ft below the floor and has spun to a random angle.
Then i was assigning a coloured glass to a window and clicking on yellow came out as blue, although still called blue in the title box. I can get the colour by choosing from the hue ribbon but to get yellow i was clicking on another colour.
Could this be an issue from the latest release or am i missing something.
Or could it be something i have picked up from 3d warehouse?

It could be something you picked up from the 3D Warehouse. It might also be a graphics card issue. It would help if you share your SketchUp model file so we can see what you’ve got going on. It would also be a good idea to go to the graphics card manufacturer’s site to download and install the latest drivers.

When you installed SU2021, did you do so correctly? That involves right clicking on the downloaded installer and choosing Run as administrator. If you didn’t or you don’t remember, you should do that now and when prompted, choose the Repair option.

Are you running SketchUp 2021.1?

I am running 2021.1.279
I just let the installer auto update and clicked the options, i didnt realiseI had to install updates as Admin
I will check that and check my graphics card updates

randomaxis.skp (143.5 KB)
This is a simple example

The model or global axes in your uploaded file are in their normal or default location and orientation. The group’s axes are not aligned with the global axes indicating that either the group was drawn in a different orientation and then rotate to upright or you moved the groups axes while the group was open for editing. The group’s axes would normally be created aligned with the model axes so if you had the model axes oriented differently when you created the group, that could explain the weird group axis orientation.

Thanks Dave
I still don’t understand why it is happening as the group s were both created on the current global axis then it shifts for no reason and all of a sudden if i apply shadows the shadow hits the floor at knee level.
Is there a way i can select the model and snap it to the axis?

I think there must be something happening in your process. Again, the global axes are in their normal location in the file you shared. You can move the goup up so the bottom of it is sitting on the ground plane (red/green plane).
After you move the group up you should fix the group axes. Easiest way to do that is to explode the group and remake it.

I wonder if you have some extension running that has something to do with the axis orientation. Or do you have a keyboard shortcut set up to change the axes that you are accidentally hitting? SketchUp won’t just move the global axes out of the blue.

That is because your model floor level is below the SketchUp ground and you have “On ground” enabled in your shadow settings. As Dave says, the best solution is to move your model up to ground level.

Everything in a SketchUp model can be moved or changed except the global axis. It stays in place.

Thanks for your help Dave, I think it may have been a wacom pen I thought was switched off but still connected by bluetooth. I dont use it for sketchup im happy with my 3dmouse.
I am going to deliver this project on Wednesday then have a sort out!
Thanks for your time

1 Like