Problems with FredoCorner Round

I am having some problems using Fredo6 Tools, specifically, FredoCorner/Round. I am trying to bevel the top edges of this table leaf but not the hypotenuse (where the piano hinge joint is). When I pick these edges and use FredoCorner/Round, I get the following error message: “reference to a deleted Edge.” This is using a 1/8" offset setting.

Is it possible that this is related to the fact that Fredo Solid Inspector reports “Short Edges - 2” for this component although SU, in it is Entity Info, indicates that this is an acceptable “solid component?” I have had some success previously in dealing with this error by changing the Short Edge Threshold. It is now at 1/16" and this had worked before but now now. Honestly, I don’t know exactly the mechanism behind the Short Edge Threshold. Can I upload a file?

Yes. You can upload the SKP file and seeing it will help us help you.

I am trying it now. I just noticed that since I SaveAs’d this component, it is no longer a component in its stand-alone file. If you need the whole file, let me know.Triangle Top.skp (23.9 KB)

Note: When you open a component file you will always be inside it, it is like being open for editing. When you insert it into another file it will be wrapped as a component.

Part of the problem is the little sections where the sides of the leaf bend near the rule joint. there’s one on each side. Are you really planning to make the top that way?


After redrawing the leaf with straight sides, Fredo Corner still seems to have problems.


The Bevel tool in the older Round Corner seems to work fine, however.

Actually, this is a gate leg table that I made about 25 years ago, so what I am trying to do is more or less draw an as-built of the table. The triangular drop leaves have always had a problem of being a sharp corner when they are down. When they are up, everything disappears into a nice 4’ square with rounded corners. I have been toying with modifying the top to sorta emulate a Zuni shape where the triangular leaves return perpendicularly to the center piece rather than at the 45 degree angle.

Yes, “rule joint” was the right description; I knew that 25 years ago.

I am going to upload the whole file. This might help you visualize the table top, and perhaps tomorrow I’ll take a couple of pictures of the table.Gate Leg Table.skp (466.9 KB)

Might be easier to treat the top as a single piece and bevel the edges all the way around. Then separate it into the pieces with the rule joint profiles.

That would probably work for the existing table configuration. However, it wouldn’t work for my intended revision - I think.

BTW, this is not urgent. It is Friday night. Don’t get me wrong, I very much appreciate your help, but if you have other things more pressing, please explore this at your convenience …

Not sure why it wouldn’t work.

I’ll look at it tomorrow. The dog is calling me for you know what.

Sounds good.

Finally got back to it. I started with the top as one piece and chamfered the edge with FredoCorner. Then I created the rule joints.

Since you have Pro, I used Trim from Eneroth Solid tools to do this. (It could be done with Intersect Faces, too, but that’s more work.) I drew “cutters” to cut the joints.Think of the volume of space a router bit would pass through while making the cut on the real board. The cutter for the leaf side looks like this. I added a transparent material so you could see the whole top. There’s no need to do that in practice, though. Note there’s only one leaf. There’s no point in making two leaves. The first component is copied and flipped in the green direction for the opposite side.

The cutter for the center section looks like this:

In both cases I copied the profiles of the joint from your model.

Now all you need are the hinges and something to keep the top off the floor. Legs are commonly used for that. :smiley: :smiley:

Gate Leg Table dr.skp (196.8 KB)

Here’s an example of a gate leg table with an elliptical top. It has a round over with a step at the top instead of the simply chamfer. I modeled it the same way by starting with the full top with the profiled edge and then cutting the leaves loose.

1 Like

I sorta hate to ask this but … round edge versus chamfer? I am going to guess that if I FredoCorner/Round the entire top and then use the cutters to split the leaves from the center piece, everything will be good. Yes? I’ll try it. Legs? I hadn’t thought of that. We’ve had that table for years and are still sitting on the floor when we use it. I don’t know why I needed to have the leaves fold either.

In your first post you used the word “bevel” so I put a bevel on the edges with the chamfer tool. You would use the same process I showed with a radiused edge created by the Round tool.

It should. The only potential issue might come in if the round over and the rounded part of the rule joint intersect. Short edges could result and might leave holes. I would use “The Dave Method” to avoid that problem.

I had coffee in my mouth when I read your post. Not I’m emphasizing “had”. :smiley:

I just tried, from scratch, 4’ square, rounded corners, weld these edges, push/pull to 12", FredoCorner Round (1/8"), selected just the top edge … and it almost worked. It rounded the top edge all of the way around except for one little section on one side. I tried to repair this by hand and although Solid Inspector indicated everything shiny, my entity info would not show this as a solid. Hmmmm?

Can you go back to just before you tried Round Corner and share the SKP file?

Here it is. I did try what I believe is the Dave Method and scaled it up 100 and still got some anomalies - different ones but still odd. Good luck. What is Uploaded is the 4’ square table at the proper thickness with the edge welded - all should be ready to Round. I was using 1/8" for the offset.
Component_1.skp (33.9 KB)

How did you round the corners? It’s strange because there’s an extra softened edge on the rounded corner nearest the origin.

FWIW, The Dave Method doesn’t work with groups. You need to use a component. First, though, we need to sort out that extra edge.

What radius do you want the corners to have? They aren’t all the same in your model.

I made a centerline along the diagonal. Offset either direction 5 5/8", then made a 2 point arc from where these lines intersected the edge with a 2.5 bulge. So, in summary, the rounded corners should be 11 1/4" apart with the 2 1/2" bulge. I am at a loss as to where the discrepancies could’ve come from. My guess would be rounding, but that still doesn’t seem right. The arcs forming the rounded corners are not necessarily tangential.

It would be hard to see the discrepancies because you are using Architectural units with precision set to 1/16". You also have Length snapping enabled which can get in the way.

Is there any reason you couldn’t make the arcs in the model tangential?