Problems with Click and Drag Translate in Thrupaint plugin by Fredo


#1

Hi Sketchup experts :sunny: ,

I’m having problems with moving texture using Thrupaint tool by Fredo.
It is a wonderful tool but in “Advanced Materials and UV Mapping in SkechUp with ThruPaint!!!” video by Justin Geis at around 6.30 he is able to adjust his texture in Click and Drag Translate mode (coordinates: rotate/move/scale appear). On my Mac they only blink. Also entire plugin doesn’t work as quickly as in Justin’s video. Would you be able to have a look if there is a way of improving that? Cube.skp (1009.4 KB)

Many thanks :slight_smile:


#2

ThruPaint is pretty complex and confused me as well. I just recently got it to do what Justin did on the curved road tutorial. What are you trying to accomplish using thrupaint? It isn’t clear to me from your Cube model.


#3

Hi Eric,

Thank you for quick reply.
I am trying to move texture on a piece of tiled skirting which was chamfered using FredoCorner (file attached), so that the grout on top and front was in line. In Justin’s tutorial it is made effortlessly but in my software the plugin doesn’t work so smoothly. When I try to adjust the texture using SELECTION section of ThruPaint it is not possible to grab any of the toggles to move/scale/rotate. They flicker and before I move mouse to any of them they disappear. Balcony_Skirting.skp (1.1 MB)
I’ve made a little video of what is happening https://discourse-cdn-sjc1.com/sketchup/uploads/default/original/3X/a/4/a4d872283b52b9c1944430b5132dcfe5c222024d.mov


#4

Hi Eric,

I just want to let you know I have figured it out. New day, fresh head it seems.
I would make a video but it would be too big for this platform.

To make a chamfered tiled skirting you need to first apply material and than chamfer:


Create a rectangle, extrude, group. Go into edit and paste in the object from which you would be sampling the texture using ThruPaint.
-In Material section select Sample Material from Faces of the Model.
-In UV Mapping select Projected UV.
-In Selection select Surface. Make sure your Axes are set to the corner of your model.
-In Surface’s submenu go to Local. Select every one of three plane options one by one by applying texture to each plane separately, e.g…: select horizontal plane in the menu and hoover over horizontal face the with the mouse until plane shows up, click and apply material. Do the same with two other planes.
To position texture so that the grout is in line on top and front faces you need to test by clicking one surface more to the left or right of the face, that switches direction of the texture.


#5

And after all surfaces has the texture apply FredoCorner :slight_smile:


#6

Good to hear! Thanks for reporting back as I’m sure others will find this useful.


#7

Thanks Eric.

I thought I will give something back to the community. These resources are really helpful.