Fredo6 Thrupaint

The scaling in Thrupaint from Fredo6 is not changing the texture to roads to follow along roads which are not straight. The texture is not aligned with a curved road. The second problem, three option translation, rotation, and uniform scaling tools is not moving the texture as it should be to adjust the texture. The other tool which changes from a single face to multiple faces on the road surface “Curviloft by spline” was added to permit the aligning for the texture. But the paint is not aligning with the faces on the curved road and the scaling tool does not work. Please see attached models with one of the Texture alignment problems.
Thanks Jeff


Lots of tutorials on Youtube:

thanks, is there a reason for the Rotation, Uniform scale and translation command tool to cause it to turn off inadvertently? I checked several tutorials on youtube but doesn’t address the specific problem

Are the faces of the road correctly oriented and the material applied on the front faces?


I reversed the faces (on the road) both times to make sure and the problem is still repeated on both sides. And the faces ( curviloft by spline ext) are correctly oriented in the same direction as the texture that is supposed to follow. The last screenshot example shows the faces correctly following the curved road and seems the thrupaint should match. How is a motion video uploaded to show more details of the problem?

You’ve probably applied the texture to the back faces (see your model in Monochrome), and the selection in ThruPaint is for Front faces only, as seen in the second photo you showed.


I posted the question related to the command tool( the second screenshot above) for the second time. Is there a chance the command tool will not respond? Such as translation, rotation and uniform scaling commands don’t respond. When the tool is applied to the texture, it doesn’t move the texture.

I answered you twice, with animated examples and the explanation why in a certain case you can’t change the texture.

Do you know the difference between the front (white) and the back (blue) face?

Can you do a simple thing and look at your model with style set to Monochrome and see if your faces are reversed?

For the third time an example in which I show you that if you have the material applied on the back faces of the road and you have the setting ‘F’ (see the second picture you presented), you will not be able to change the texture (move, rotate, scale).


setting ‘F’

1 Like

I was referring to the command tool. The faces which are not aligning is a different problem as well. But the priority is the command tool. Without it, becomes useless for the entire model. First, what can disable the command too?l Because its not working.

The best way to show the problem, is in a motion video. But not sure how to upload it

I’ve reversed the faces several times and used turned on and off the setting in the second picture as suggested, Not sure what is monochrome though.

As I showed in the other gifs


You can upload an animated gif or movie just as you uploaded the photos (probably via Drag & Drop).

What is ‘the command tool’?

2 project file.skp (967.1 KB)

I uploaded the same file with the model that won’t activate the command tool in thrupaint in the “rotation” “uniform scaling” and “transition” command icon. When activating the Brush icon on thrupaint, the wheel icon free-wheels and doesn’t move the texture.

You need to learn the basics of SketchUp, about the faces, front (white) and back (blue), and the ‘Styles’.


the texture isn’t aligning. I’ve used the tool for a while and worked before. It was disabled and now won’t align with curved surfaces nor the command tool works. I know how to use both. There is probably an adjustment problem

It works for @mihai.s and it works for me, so It sounds like you are not doing something correctly.
The file you uploaded still has a reversed face.

1 Like

Using the drop down menu after right clicking on the mouse, there’s the reverse face option and tried to apply texture on both sides as well as using the command tool to move the texture on each side. But there was no movement. The last screenshot shows the same problem

Is the blue or white side for the texture to be applied and accepts the thrupaint command tool in order to move it properly?

how are the faces corrected to accept the thrupaint and movement tool on the blue or white side?

Which settings? The Thrupaint menu bar? I attached a copy of the menu items. As mentioned, I’ve used thrupaint for a while and it quit working recently