Problem with zoom?


#1

When I zoom in and out, the view often resets to a top view of the point of origin at a high zoom for no apparent reason. This seems to happen more often when I zoom in/out quickly, but also happens randomly. The blue background of the urban planning template I am using has also disappeared. I have no idea what is causing the problem. Sorry if I am being ignorant, I am very new to SketchUp. Thanks for any help.

GI2.skp (469.9 KB)


#2

There appears to be 3 stray pieces of text in the model somewhere.
There’s a way to fix it, but I see others are looking at the file, they may find them…


#3

Often when there are entities at a long distance from the origin weird camera behaviour occurs.

If you go to camera>parallel projection. The background does not display as you would expect when orbiting.

If you set the camera>perspective. The background displays in a normal manner when you orbit the model.

In the image below there are 13 pieces of text in the model, however there are only 10 visible in the model space. That probably means there are 3 pieces of text or leaders floating around somewhere causing the camera to behave strangely.

I tried to find and delete the 3 pieces, to no avail. What I then did were selected all the model and copy/pasted it into a new file, with the urban planning template you mention. Hoping I wouldn’t take the 3 stray pieces with it.

The shot below shows now only 10 pieces of text in the model statistics and 1 less edge that I think must have been floating too. The model appears to be behaving in a more normal way.

This is the new file G12 IanT.skp (100.6 KB)


#4

I’m on my phone now so can’t examine your model but I wanted you to know that texts flying off to extreme distances is a known bug that strikes when people use them to annotate a basically planar model, not something you did wrong per se. So far nobody has found a reproducible sequence of operations that triggers the bug.

Edit: Got to my computer. Indeed, your model has three texts that gone singular. I didn’t find any problems with stray edges. The original text strings were:

  • “CONDOMINIUM”
  • “BUILDING”
  • “SHOPHOUSES and SHOPPING MALLS
    (CONTINUES SOUTH)”

#5

The new file works, Thank you for the help and the useful tips. I will take the annotation/stray text bug into consideration.


#6

Just tried finding stray items in my file because I was having the same issue. Worked perfectly. As soon as I found some items way out in space and deleted them, problem went away.