Problem with the management portal seeing my pro subscription

Hello all. Not 100% sure if this is the right place to post this but here goes.

I recently reset my laptop to free up hard drive space and do a general cleanup.
This has become an issue with sketchup because the management web portal does not show my pro subscription on a page that I can download it or manage it. the :my "products page " says “You currently have no plans or products assigned to you.” The "members page " shows the pro subscription but when i click to modify access, it doesn’t come up and the radio buttons don’t work for what is shown. (Free And Studio trial ) The “Plan Settings page” only SketchUp free and the Studio trial that I downloaded as a workaround to install a pro version to work on an ongoing project.
I might consider moving to Studio but have ran into an issue downloading V-ray because the last tech I had contact with revoked it? So eventually when this is worked out I would like to give it a try, mainly for v-ray.

As directed by the 1st tech support contact I shut down all instances of SketchUp running on the computer ( 2023 only) and deleted the “login_session.dat” file. then relaunched sketchup and the management portal. I have done this twice. Nothing changed either time.
Now the tech is saying to uninstall every thing including extensions and start over. I am reluctant to do that because SketchUp is running fine and I need to use it. I am open to doing that next week when I have a little spare time , but it seems to me to be a web portal issue, not a program issue. I am only using the Enscape extension right now but will be installing profile builder and round corner soonish.

Can someone explain to me why the web portal shows that I have the product on one page, but will not let me download it or manage it. I hope to be purchasing a new laptop in about two months and would like to make that set up process as seamless as possible.

I use one email that is acknowledged on the web portal but I do sign in thru google. Always have. Not sure if that can cause any issue?

I believe this issue has been forwarded to a specialist under ref:_00D4081l2._500Do7qoQE:ref
but would love to know the reasoning behind a full uninstall from my end for a web portal issue, or why this is happening at all.

Also curious why I see a free version on the portal when I don’t think I ever signed up for it. Definitely never used it. The 1st tech thought it might be something with the email being attached to that version.

Lastly. Who do I talk to about extending the studio trial due to my not being able to use it during this issue. will that be possible?

Thanks sincerely for any insight or a full resolve of this issue. Be Well.
Dave G

When you are signed into here:

with the email you use in the forum, check to see what the account is selected. The different accounts you could be looking at are on the left, below the edit profile link:


For your Pro subscription, that is in your ‘sustainable’ work account. Make sure that one is selected.

I only see your Pro subscription, and no Free entitlements. If you are seeing Free ones, you may be selected to a different account, or you’ve signed in with a different email address.

Because that email is also admin, you may see a Free entry, and a Trial entry, neither of which are assigned to anyone at the moment. Try going into Members, select yourself in the list, and see if you can modify the Studio trial to give yourself access.

That trial is still due to run for another 25 days, if it could be extended that would only make it be 5 days more. Hopefully you will have had enough time to evaluate the Studio features. If not, ask again for an extension closer to the end, which if we can do that would give you a new 30 days.

For the question of reinstalling things to see if the Support person had a good idea, you could download and install SketchUp 2022. If that goes well, and signing in and using your subscription issues all go away, you could keep trying the Studio features in 2022 while you get 2023 fixed at your leisure.

The 2022 installer is here:

If you do try 2022, and end up with both 2022 and 2023 behaving themselves, make sure to open 2022 and sign out, so that you can then sign in with 2023 on a second PC.

1 Like

Hi Colin. Thanks for the quick reply. something is wrong.
Maybe with the way I’m logging in ? I logged in thru that link. I do not see the personal account as shown on your screenshot. I do need to log in thru Google from that link page. It will not let me log in thru straight email. Possibly relevant ? But this hasn’t been an issue in the past. I believe I remember when it was setup that Trimble said it would be the only way to log in. But my memory might be incorrect.

All other pages show everything as described previously. No change. My Products page shows
“You currently have no plans or products assigned to you.” But I cant assign pro anywhere I can see.

SketchUp pro is only shown on the Members page but is unassignable. When I click to modify product access, Free and Trial are shown, the radio buttons for those do not work. try to select and nothing happens. Pro is not shown at all.
Plan settings page shows trial and Free. No Pro. I’ve tried to switch accounts but that hasn’t worked either.
I can upload screen shots of the pages I see if that would be helpful.

The last tech stated that this issue was being directed to a specialist. Im curious if that is you or will I be receiving a separate email and should direct screen shots there.

Possible also not relevant. But this is the only issue I’ve experienced with this computer clean up. other 3d software, photo editing apps, etc. this does seem to be an isolated issue.

Thanks again for your help, I imagine / hope in the end this will be a small thing that causes a glitch and in retrospect an easy resolve.

The Personal in my screenshot was to show the position I was referring to. In your case it should be showing your company name.

I did work in Support for two years, which is why I know about these issues, but the person who your problem is escalated to is not me. It’s getting late on a Friday, if there hasn’t been a follow up I imagine it won’t happen before Monday.

I will tell a colleague in support about your post, so they can check into what the progress is on your case.

I found out who your case was escalated to, and for what it’s worth she is based in London, so hopefully will have some news early in our work day on Monday.

Thanks. Have a good weekend

So sadly the saga continues. From the original tech support person referring to the specialist.
Quote: "They created a 1YR entitlement and assigned it to you. "
The issue with that is I had a two year license purchased Nov 18th 2022. It used to say that on the members page. Now I have a one year license ? wt* ? This seems a workaround that will cost me a year subscription price. Also still no Studio access. LOL this has gone on for a week now. I really thought it would be an easy fix.
Also I’m curious why an entitlement needs to be used at all?

Just an update. This has been worked out except for the Studio trial part.

This topic was automatically closed after 186 days. New replies are no longer allowed.