Problem with Opening SketchUp


#1

My SketchUp has not been able to open for the last two days, it has only been coming up with bug-splats and I have an assignment coming up and need to use this program. I am using the schools laptop and has only started playing on thursday.


#2

Have you installed plugins lately, which OS are you using?


#3

have not installed any plugins ever. I am running a 64-bit Os


#4

You may have an autosave file attempting to open, did the program crash last time you were using it?

Try holding shift while you launch SU. This should open a fresh version without attempting to load the last file.


#5

I had closed my laptop down correctly the night before and then the morning after it had an immediate bug-splat. thank you but holding shift doesn’t work


#6

and now is always asking me for permission to open it ?


#7

I found one of your call stacks, and I expected to see GL issues, but I’m guessing it’s Ruby related, as I saw SketchUcation_loader.rb loading a lot of plugins. Can you try disabling your ruby plugins and see if that helps?


#8

how can i disable them if i cant open haha wouldnt have a clue thankyou


#9

Since you haven’t filled in your profile correctly I’ll make an educated guess.
You say Dell, so Windows, perhaps Win7.
And you haven’t said the specific version of SU so Perhaps it’s SU15.

The default location for plugins for SU15 on Win7 is
C:\Users\YOURUSERNAME\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins

If I have guessed correctly, find this folder and Rename it to DisabledPlugins

Now try to start SU again.